Realtek USB Wifi problems

I have a BBB running Angstrom 3.8.13. I have a Realtek USB Wifi, lsusb shows
Bus 002 Device 004: ID 0bda:818b Realtek Semiconductor Corp.
I put 8192cu.ko in /lib/modules/3.8.13-00720-g4202df2-dirty
I did insmod 8192cu.ko
lsmod shows
Module Size Used by
8192cu 445685 0

dmesg shows [ 6.699120] usbcore: registered new interface driver rtl8192cu

The interface does not show up with ifconfig

What am I missing?

Thanks in advance,

What does this show for your system ?
root@wgd:~# apt-cache search firmware-ralink
firmware-ralink - Binary firmware for Ralink wireless cards

And if that shows what does:
root@wgd:~# dpkg -l | grep ralink

Show for you ? It does not return anything for me, but I also do not have a realtech wifi adapter installed either . . . Anyway, if you show that package available through apt-cache search( run apt-get update first ), and dpkg does not report it as install. Install that package MAYBE needs a reboot, then run ifconfig again.

Neither command exists on my system. Nor is it connected to the Internet. I am connected directly to my laptop with an Ethernet cable. I have the Chipsee 7" display and installed the Angstrom image on the DVD that came with the display. I did reboot.

You have opkg . . .

root@beaglebone-exp:~# opkg list | grep ralink
linux-firmware-ralink - 1:0.0+r8-gitAUTOINC+c530a75c1e6a472b0eb9558310b518f0dfcd8860-r8.1 - linux-firmware version 0.0+r8-gitAUTOINC+c530a75c1e6a472b0eb9558310b518f0dfcd8860-r8

Ok, so I do believe that Angstrom does use dpkg too, but it’s modified, But ah here we go:

opkg list-installed |grep ralink``

If that does not show anything then opkg install linux-firmware-ralink, reboot, reload your drivers if needed, then check ifconfig again.

And you probably don’t want to hear my alternative is that does not work :wink: It should work however.

root@beaglebone-exp:~# opkg list-installed |grep ralink
linux-firmware-ralink - 1:0.0+r8-gitAUTOINC+c530a75c1e6a472b0eb9558310b518f0dfcd8860-r8.1

At this point, you're on your own with google. Unless someone else here who
is familiar with Angstrom knows what your problem is.

Thanks for your help William. I will try to somehow upgrade the image.

No problem. Yeah, I knew you probably did not want to hear "upgrade to a
latest Debian image", but most people here who would be able to help you
troubleshoot your problem are going to be using Debian or maybe ArchLinux.

It is possible if you search for related rPI problems you may be able to
parse from what you're reading into "Angstromese", but there are no
guarantees . . . And unfortunately lately it seems if you need modern
wireless support, you're going to maybe need a current image.

It’s that small miniature dongle right?

Disable HDMI and suck a little USB extension cable.

Your fighting the HDMI gnd plane that interferes with the wifi radio…


Yes, small dongle. It is plugged into a powered USB hub. Disabled HDMI in uEnv.txt. Rebooted and still no joy.

I tried the Debian image on the Chipsee DVD earlier today and no luck there either, but could easily switch back to that. Other choices on the DVD include Linux-EZSDK and Android. I would welcome any suggestions for other OS’s that support the Chipsee 7" display cape.

Todd, how are you powering your board ? Hopefully not via USB . . .

5V, 3A wall wart.

I switched to Debian. 3.8.13+. Went through the same steps, with no luck. I have another USB Wifi device as well. It is a 148F:5370 Ralink 5370. Messed with that a bit and got it to work. Thanks all!

That’s an 8192eu, not an 8192cu