Record audio from beeagleboard with Froyo

Hi I have a problem with beagleboard and Android Froyo I will
appreciate a lot your help

Does any body has been able to record a .wav file on beagle board with
pre build Rowboat project ?

I can check the controls with

alsa_amixer controls

get the value of a control with

alsa_amixer cget numid=25

set the value with

alsa_amixer cset numid=27 1


alsa_aplay /dev/urandom

make a random noise :slight_smile:


alsa_aplay song.wav

play the song perfect, the problem is that I can not record


does not exist

so I make a symbolic link on /system/bin

ln -s alsa_aplay alsa_arecord

and then

# alsa_arecord o.wav
Recording WAVE 'o.wav' : Unsigned 8 bit, Rate 8000 Hz, Mono

Interrupt with CTRL + C

^CAborted by signal Interrupt...

Then when I tried to reproduce with

alsa_aplay o.wav

I just hear noise , nothing from the things that I record

I am doing something wrong ?

Does any body has been able to record ?

Besides with the Sound Recorder application after record it stop
unexpectedly after recording.

Thanks a lot for your help


Victor Rodriguez

Back a week or so ago I reported the same problem and I was told that the socket won't support a microphone as it expects Line-in levels, so I'm building a pre-amp for my eletret mic. This evening I have been scrounging parts from junk boxes and spare boards to build the attached circuit.


HI Sid thanks for the quick answer

Are you sure that is a hardware problem ?

Have you tried on another File System ? like Angstrom ?

It make me noise to believe that in all this years of be developing
with beagle board no one has been able to record even in any another

I will make more test and if this is right then I will report the bug
with the vendor

Thanks a lot for your help


Victor Rodriguez

Looking for a compatible , low-cost camera module for BB-XM (low resolution is fine)
Anyone with experience / thoughts on products from leopardimaging ?
Part # LI-LBCM1M1 ($30.00) looks promising.



I have the same problem with Angstrom and Ubuntu. This is cut and paste of the reply.

Hi sid,

Were you able to fix the issue using Audio Amplifier?


I didn't get to test it properly, the circuit I used seemed to be too sensitive, so I was overmodulating, but at least there was sound.

I've since got a XM that has a problem with microSD corruptions on 16GB and 32GB cards. Using Ubuntu I can load up the distro fine, but if I try to add many more packages I get many I/O errors and a reboot fails.


By the way have you worked with any sound processing in beagle board? Can you recommend any libraries?