[Release] TI Android FroYo DevKit V 2.2 for Beagle XM and AM37x/DM3730 EVMs

Hello all,

As a follow up to our TI Android FroYo DevKit V 2.0 release in Oct
2010, we hereby announce the availability of TI Android FroYo DevKit V
2.2 for AM35x, AM37x, OMAP35x, DM3730 devices. The release has been
validated on AM35x/DM3730/AM37x EVMs and Beagleboard rev C4/XM.

Thanks a lot for your help and support during review, bug fixes and

Thanks to Mentor Graphics team for helping us integrating DSP
(hardware) accelerated CODECs.

What's new in this release?
DSP (hardware) accelerated multimedia CODECs (720P MPEG4 ASP and H.264
MP/HP) for DM3730, Power Management, WLAN (WL1271) on AM37x EVM,
Bluetooth connectivity for OPP, A2DP profiles on AM37x EVM, Camera
Image capture on Beagle XM, Fastboot utility for firmware upgrade,
NAND UBI File System based booting, UI and video on S-video, hardware
accelerated dynamic rotation for Video pipeline, etc.

The features from previous release like USB Mass Storage, Audio
record/playback, Keypad, Touchscreen, etc are still retained.

DevKit release V2.2 can be downloaded from:
Sitara page :
Davinci page :

Explore latest exciting features with TI Android DevKit V2.2
See Beagle XM analyzing and printing live BarCodes and QR Codes
through Camera module, Go wireless with WLAN and Bluetooth support on
AM37x EVM, Enjoy 720p DSP (hardware) accelerated multimedia, Upgrade
Firmware dynamically by flashing on board NAND with Fastboot, Improved
power management, leverage RowboPERF app for performance measurement &
benchmarking, and lot more... (see flash video)

Please give us your feedback on improvements.


This release looks really tough! Great work!

2011/1/31 Syed Mohammed, Khasim <sm.khasim@gmail.com>


Release notes and user guide of V2.0 don't mention touchscreen. In
fact: my usb touchscreen doesn't work. Does new version include this
peripheral?: Docs are still not mentioning anything...

Thank you very much.

I probably am missing something. In the released manifest I saw:
<project name="packages-apps-gallery3D" path="packages/apps/Gallery3D"

but on rowboat's website it is "packages-apps-gallery3d", I had to
change 3D to 3d to checkout, anyone else has seen the same thing?


Hi Khasim,

Android DevKit V2.2 seems can’t work on my BeagleBoard xM,
here is the step and log:

1, download the beagleboard-xm.tar.gz
2, tar -xzvf beagleboard-xm.tar.gz
3, cd beagleboard-xm
4, sudo ./mkmmc-android /dev/sdb

wait to complete.

Insert the uSD card to BB-xM and power up.
Wait for long time, but nothing display on screen (DVI port).
The Angstrom can display something on screen,
So the hardware is OK.

below is the log:

Can you please provide the logcat result as well?
It seems process Zygote is not starting up in your case .


I just installed the Beagle image on a rev C3 board, it’s pretty cool. With some tweaking of the kernel command line, I got it working in 1280x1024 native display resolution. Only thing I miss is the DSP support, so:

  • is it possible to build a rowboat image with DSP support for the OMAP3530?
  • is such a (pre-built) image available somewhere or do you plan to release?


I have similar output from serial, my screen had a big Android string
displayed for 30 minutes, still nothing more. I noticed IOWAIT is 99%
most of the time, I start a reboot by typing in 'reboot', then Android
fully came up but with a few errors:
"EXT3-fs error (device mmcblk0p2): ext3_add_entry: bad entry in
directory #64397: inode
some apps can not run after Android is up, and IOWAIT stays high(99%)
all the time.

will try a different MicroSD card, I understand the first boot time is
long, but how long is normal?


Just tried a new MicroSD card it's up in 2 minutes fully, with only
one warning/error message on serial port:
binder: release 1063:1063 transaction 1340 out, still active
binder: 912:1028 transaction failed 29189, size 4-0
binder: send failed reply for transaction 1340, target dead
the card makes a big difference.



The rootfs in DM3730 folder can boot directly on Beagle rev C4, this
has DSP CODECs, we have tried this on XM only, give a try.


I guess the problem with the long time waiting is that XM powers SD card with 3.0V but this is at the edge of the specification. Probably it requires to increase the SD supply to 3.15V - the maximum TPS65950 can give.

2011/2/1 Syed Mohammed, Khasim <sm.khasim@gmail.com>