requires to be root to ping!!

ubuntu@arm:~$ ping www.google.com ping: icmp open socket: Operation not permitted ubuntu@arm:~$ sudo ping www.google.com PING www.google.com (74.125.236.145) 56(84) bytes of data. 64 bytes from bom03s02-in-f17.1e100.net (74.125.236.145): icmp_seq=1 ttl=55 time=42.1 ms 64 bytes from bom03s02-in-f17.1e100.net (74.125.236.145): icmp_seq=2 ttl=55 time=41.6 ms 64 bytes from bom03s02-in-f17.1e100.net (74.125.236.145): icmp_seq=3 ttl=55 time=41.5 ms 64 bytes from bom03s02-in-f17.1e100.net (74.125.236.145): icmp_seq=4 ttl=55 time=42.1 ms 64 bytes from bom03s02-in-f17.1e100.net (74.125.236.145): icmp_seq=5 ttl=55 time=43.3 ms

RIP ubuntu for beagebone. I installed ubuntu-14.04-console-armhf-2014-05-06 to check if wvdial is improved; I am unable to dial my 3G modem. I was struck dumb when ping say Opertion not permitted. and it requires root previlage to do so!! previous version of ubuntu is halting as if some one pressed power button. I posted the bug at https://groups.google.com/forum/#!category-topic/beagleboard/support/advanced/beaglebone-black/software/ubuntu/OXZpfmolHu0 to which I got no answer.

I feel beaglebone community is dying!!!

ubuntu@arm:~$ ping www.google.com
ping: icmp open socket: Operation not permitted
ubuntu@arm:~$ sudo ping www.google.com
PING www.google.com (74.125.236.145) 56(84) bytes of data.
64 bytes from bom03s02-in-f17.1e100.net (74.125.236.145): icmp_seq=1 ttl=55
time=42.1 ms
64 bytes from bom03s02-in-f17.1e100.net (74.125.236.145): icmp_seq=2 ttl=55
time=41.6 ms
64 bytes from bom03s02-in-f17.1e100.net (74.125.236.145): icmp_seq=3 ttl=55
time=41.5 ms
64 bytes from bom03s02-in-f17.1e100.net (74.125.236.145): icmp_seq=4 ttl=55
time=42.1 ms
64 bytes from bom03s02-in-f17.1e100.net (74.125.236.145): icmp_seq=5 ttl=55
time=43.3 ms

RIP ubuntu for beagebone. I installed ubuntu-14.04-console-armhf-2014-05-06
to check if wvdial is improved; I am unable to dial my 3G modem. I was
struck dumb when ping say Opertion not permitted. and it requires root
previlage to do so!! previous version of ubuntu is halting as if some one
pressed power button. I posted the bug at
https://groups.google.com/forum/#!category-topic/beagleboard/support/advanced/beaglebone-black/software/ubuntu/OXZpfmolHu0
to which I got no answer.

You might have better luck posting the bug to bugs.elinux.org

What are the permissions on your /bin/ping?

They should be set to suid and be owned by root.

On my x86 ubuntu machine I see:

380 >ls -l /bin/ping
-rwsr-xr-x 1 root root 44168 May 7 14:51 /bin/ping*

The s (rws) means setuid.

ubuntu@arm:~$ ls -la /bin/ping

-rwxr-xr-x 1 root root 34820 Mar 15 06:27 */bin/ping*

why is sticky bit not set in the ubuntu-14.04-console-armhf-2014-05-06?

Nah, it's doing great. I think you ran into an obscure bug in Ubuntu:
/bin/ping has to be privileged to access the ICMP functions, and used
to be SUID root. Now, however, it's using capabilities, which are not
that well displayed (the only indication from 'ls' is red background,
not explained anywhere). You have to know what to look for:

getcap /bin/ping
/bin/ping = cap_net_admin,cap_net_raw+ep

I can't check now but I bet you that on your system it will not have
those capabilities --- or they will be for some reason ignored by the
kernel.

It's also the summer and the weekend. We got better things to do! :wink:

It looks like ubuntu broke ping, i'm not suprised.

Fix listed here:

https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/1302192

Regards,

ubuntu@arm:~$ ping www.google.com
ping: icmp open socket: Operation not permitted
ubuntu@arm:~$ sudo ping www.google.com
PING www.google.com (74.125.236.145) 56(84) bytes of data.
64 bytes from bom03s02-in-f17.1e100.net (74.125.236.145): icmp_seq=1 ttl=55
time=42.1 ms
64 bytes from bom03s02-in-f17.1e100.net (74.125.236.145): icmp_seq=2 ttl=55
time=41.6 ms
64 bytes from bom03s02-in-f17.1e100.net (74.125.236.145): icmp_seq=3 ttl=55
time=41.5 ms
64 bytes from bom03s02-in-f17.1e100.net (74.125.236.145): icmp_seq=4 ttl=55
time=42.1 ms
64 bytes from bom03s02-in-f17.1e100.net (74.125.236.145): icmp_seq=5 ttl=55
time=43.3 ms

RIP ubuntu for beagebone. I installed ubuntu-14.04-console-armhf-2014-05-06
to check if wvdial is improved; I am unable to dial my 3G modem. I was
struck dumb when ping say Opertion not permitted. and it requires root
previlage to do so!! previous version of ubuntu is halting as if some one
pressed power button. I posted the bug at
https://groups.google.com/forum/#!category-topic/beagleboard/support/advanced/beaglebone-black/software/ubuntu/OXZpfmolHu0
to which I got no answer.

I feel beaglebone community is dying!!!

While it might seem frustrating, the BeagleBone community is one of
the best I have seen in a long time.

Not to beat a dead horse... But the challenge is for the communication
channels to keep pace with the technical development. Currently the
project is going through a new hardware release, a second vendor is
manufacturing BBB rev C, a major default OS change from Angstrom to
Debian, and more than 10 distros are running on the beaglebone black.

Nice work everyone.

David

Happy to find community is alive! I hope my 3G modem works; I think insufficient power from the hub. I couldn’t find wvdial package in angstrom and frustrated to compile wvdial source. I really thought BBB community is loosing in addition to these bugs my friends have gone for Arduino n raspberrypi despite BBBs elegant capes n powerful specs.

please make BBB’s one n only USB port to be repluggable while running.

It's had "hotplug" support for awhile. Some devices break the usb spec and
require more power then what the port can handle at hotplug time. So make
sure you are using an external power supply (and not the usb cable). Next,
usb is a complete hack on 3.8, so switch to v3.14.x if usb is important to
you. Note v3.14.x is lacking capemgr.

Regards,

Next, usb is a complete hack on 3.8, so switch to v3.14.x if usb is important to you. Note v3.14.x is lacking capemgr.

I need UART1 and USB. My application enables UART1 during startup; I found a dtbo to enable UARTs on internet. In v3.14.x can I access /dev/ttyO1 out of box?

No. We do not do special requests like this. Moving it to make you happy will make a lot of other people that use the debug cable very unhappy.

Gerald

Yes, enabling ttyO1 is easy with v3.14.x

In /boot/uboot/uEnv.txt

Just un-comment this line:
https://github.com/RobertCNelson/omap-image-builder/blob/master/target/boot/beagleboard.org.txt#L26

Full steps:

cd /opt/scripts/tools/
git pull
sudo ./update_kernel.sh --beta-kernel

(reboot)

edit: /boot/uboot/uEnv.txt
add: cape=ttyO1

(reboot)

use newly enabled serial port.

Regards,

Yes, Agreed. But that is not out of the box.

Gerald

Is that all?? Does ur steps install v3.14.x kernel as well???

Hi Nelson, I installed 3.14.x from http://rcn-ee.net/deb/raring-armhf/v3.14.4-bone4/install-me.sh

and then as you said I looked in /boot/uboot/uEnv.txt for line
https://github.com/RobertCNelson/omap-image-builder/blob/master/target/boot/beagleboard.org.txt#L26
and I didn’t find it in the file.

Hi Nelson, also I didn’t find /opt/scripts/tools/ folder but instead there is /opt/boot-scripts folder. Are U sure that your procedure is regarding ubuntu on BeagleBoneBlack??