Restore commercial BBBlack Industrial

I have removed a BBBlack Industrial from a piece of equipment that my employer discarded; a deep freeze storage cabinet. It was mounted on a motherboard that looks like a custom and elaborate cape. In addition to a WinStar WJ70A3SIAGDNT0# 7.0" TFT LCD, all of the freezers sensors plug in to it. There must be 10 board mounted connectors.

I am new to BBB having just found this device in a scrap pile and curiosity made me look into it more. I would like to restore it to factory original so I can use it. I suspect the OEM that was using it has customized software running on it, or similar. I have decent Arduino experience and very little Pi experience.

When I plug in the BBB to my Win10 PC via USB, nothing happens on the PC. No USB device found, nothing appears in Device Manager, no drive in file explorer. It looks like the BBB boots up, the LED’s dance and the heart beat runs. I plugged into the mini HDMI but nothing appears on the monitor.

I downloaded the “AM335x Debian 11.7 2023-08-05 4GB eMMC IoT Flasher” image. Do I just copy that .xz file to my MicroSD card, restart with boot button down and I’m good to go? I’ve done that and nothing seems different.

I know I’m doing something wrong, no idea what. Any help would be appreciated.

1 Like

You will need to uncompress the downloaded file and then use a disk imager to write the uncompressed image to the SD card.

This seems quite popular https://etcher.balena.io/

Neat!

Thank you. I see that now. I’ve not used or seen a .xs file before so didn’t realize it was a compressed file. I’m eager to try it this evening.

Balena Etcher will uncompress *.img.xz internally, so no reason to pre-compress the file…

Regards,

I wouldn’t go running a flasher on that (putting a default file system image onto the onboard eMMC filesystem) until you’ve managed to back it up, or at least collect /boot/uEnv.txt and the associated device tree blob files.

Also, your best bet to see the action of the existing firmware will be to watch it through the console port J1 , and an FTDI serial cable (3.3V TTL, async, 115200,n,8,1).

I have no need for anything that’s on the unit right now. It’s been discarded and I pulled it out of a trash can, essentially. I want to be able to use it but as it sits, I can’t get it to do anything; web server access, HDMI output, File Explorer, nothing. Hence, flashing the unit to stock.

I’ve downloaded an image, extracted it and have built the disc image on my MicroSD. I’ve booted with the boot button in and MicroSD in the slot. Seems like things go fine but the instructions I’ve seen say ALL of the LED’s should go out. When I flash the device, one of the four LED’s stay on after they all finish their dance and it’s a different LED on subsequent retry’s. It’s like the procedure is locking up and different spots.

I remove the MicroSD and reboot and it just goes back to what it has been like since I started and I can’t get anything to work. Could my 128GB MicroSD card be too big for the BBB to use?

I suspect I’m not flashing the unit correctly or I’m using the wrong file. I don’t know at this point.

Sounds like you didn’t use the eMMC flasher image… Please share the file name that you used…

Regards,

I listed that in my OP; AM335x Debian 11.7 2023-08-05 4GB eMMC IoT Flasher

If you can, please share the boot/flashing log from j1 (usb serial)…

Regards,

I don’t know how to do that, nor do I have the FTDI cable to do it.

Okay… Well insert microSD, hold the boot button, insert power…

Within a minute you should see the classic cylon pattern… within 5 minutes, it should ‘stop’ and shutdown or all led’s will flash on and off (thus an error)…

it it does anything else, login with the mciroSD, and run:

sudo beagle-version

Regards,

Flash Video

i don’t know why teh video locks up at 0.47, but up to that point, it’s flashing (cylon) pattern…

the biggest problem, the flashing procedure maxes out the current draw off the processor, there is a good chance with usb power, the flashing will fail… It’s recommended to use the 5VDC power jack…

As long as the cylon pattern stops and the board shut’s down it worked correctly…

Regards,

It’s not the video that’s locking up, that’s the BBBlack locking up at 0:47. The video continues for another 45 seconds to show that the BBBlack didn’t continue for some time.

I ran the flash again with a barrel plug and I get the same result. Locks up with an LED (3) on. Could it just be I have the wrong file I’m trying to flash?

I have a logic pirate, though I’ve never used it, as well as an Arduino. I’m going to setup up one of them to use the J1 connector, pins 4 and 5 from the looks of it, and see what I can see. No idea if that will be useful or not.

Okay, i didn’t even see the camera move, so yeah…

Sadly, led (3) doesn’t mean anything, as the cylon task just cycles on it’s own:

Yeah, a 3v3 Arduino would work just fine to convert the rs232 on j1 to a usb…

Regards,

That board you found may have a smaller EMCC device. I have found that the newer images no longer fit on my old BBB boards. Same issue as you mentioned, it flashes the cylon pattern for a while and then fails by hanging. I now run these boards directly from the SD card with the added benefit of much more storage to work with.

Thank you petski, that seems to make sense and aligns with what I am seeing. Odd that would happen, but who knows. I’d like to look into the eMMC capacity that I have and truly determine if this is the case. I’ll just flash an older image that fits if I need to. At this point I’m not too worried about latest and greatest, I just want to be able to play with it.

On a side note, I was getting an HDMI signal this weekend and the Linux duck with a blinking cursor appears in the upper left corner of my monitor. However, when the board locks up so does the cursor and it’s back to nothing.

Thank you petski, you were correct. Booting from SD is working just fine. I have “bone-debian-10.3-iot-armhf-2020-04-06-4gb” running right now. I don’t seem to be able to flash my eMMC without locking everything up. I would like to have a desktop so that’s my next adventure.

Hi there, you can try my instruction below to flash eMMC for your BBBlack:

Step1: Download minimal version of BBBlack eMMC Flasher image (because it is lightweight and has the basic OS for booting up BBBlack)

-Reference link:

-I recommend download this file: am335x-eMMC-flasher-debian-11.7-minimal-armhf-2023-09-02-2gb.img.xz 10

-You may need to verify the checksum of your downloaded image vs source to avoid any issue could happen later

Step 2: Download “balenaEtcher” software (select the right version for your PC), it is recommended tool to flash image to microSD card

-Please use microSD card storage <= 32GB since there’s an issue with larger storage (happened to me) cause failed to flash image to Beagle Bone

Step 3: Run balenaEtcher as administrator, select the image downloaded from Step 1, select your microSD card, click “Flash” and wait till Flash completed

Step 4: Disconnect BBBlack power, insert microSD card to BBBlack, connect BBBlack power, wait until Flashing process completed

-During Flashing process, BBBlack’s User LEDs should blinking in order for example: 1-2-3-4, 4-3-2-1 until the flash process finished. When flash process completed, BBBlack will power off (if you connect BBBlack’s UART debug to PC, you will see all the messages of the flash process)

Step 5: Disconnect BBBlack power, remove microSD card, connect BBBlack power again

At this point, your BBBlack should work normally

If there are any failures, you should connect UART debug of BBBlack to PC to monitor what’s happening