REV B6 USB OTG as HOST problem

Hi I been reading over and over looking on how to solve his but i
havent found the answer.

SO basically i have the same problem a lot of people had trying to
configure the USB OTG port of the beagle as Host.

I already have shorttened pin 4 and 5 so you can rule that out.

i already tried the
1.- modprobe g_zero
2.-echo host > /sys/devices/platform/musb_hdrc/mode

whitout any succes. i always get a FATAL: error inserting g_zero <path
2.6.32> Device or resource busy...

Yes im using a power supply to power up the beagle.
and yes im using a hub with power supply so it doesnt takes power from
the beagle.

I check pin 1 and for some reason its always 0 (Showing that
definitively the beagle is not changing from OTG to host).

Im using the latest Angstrom from http://www.angstrom-distribution.org/demo/beagleboard/
which is also a problem because i dont know which file to get (Im
talking about version) my beagle is up and running i can vnc through
OTG and has internet access. However the next step in my project was
to add some peripherals.

Im pretty sure that the problem is related to the version of Angstrom
or Uimage or boot or ine of those files there. However without knowing
which one should I pick i wouldnt change it jut like that. SO PLEASE
is someone has a REV B6 and it made his OTG work as HOST tell me the
SECRET!!!!

I plug in the proper otg cable and it just works when using angstrom on my b6 boards

Hi! I have the exact same problem om my revC4 BB.

Ångström worked fine, but with Debian and Ubuntu i only get the
"install" screen on my monitor that tells me to select install
language..
- Of course without any keyboard detected I am stuck.

Help is greatly appreciated.

Hi! I have the exact same problem om my revC4 BB.

Are you sure? the original poster is using the otg port in host mode,
you might be using the ehci..

Ångström worked fine, but with Debian and Ubuntu i only get the
"install" screen on my monitor that tells me to select install
language..
- Of course without any keyboard detected I am stuck.

Help is greatly appreciated.

lets start with the hardware, which usb port, are you using a usb 2.0
hub? keyboard connected to said usb 2.0 hub?

beyond that, can we get a serial boot dump?

Regards,

Hello,

         I had the same thing with the demo image of Ubuntu from the
beagelboard webpage. I solved it by using rootstock to create a
minimal image which did not ask for the language - everything came up
fine and I could then go ahead and install the windowing toolkit I
needed with apt. I did not use the OTG though but the other USB port
but I had teh same problem of the keyboard not coming up in the Ubuntu
demo image - yes it was running through a USB 2.0 hub :).

Cheers,

Neil

Thanks for your answers!

Due to the fact that the OTG port worked fine under Ångström, i continued using this port for my emDebian install.
When i measured pin 1 on the OTG, it was always grounded, thus not operating in “host-mode”, even though pin 4 and 5 were connected.
The solution proved to be very simple. - Use the powered USB 2.0 hub in the USB A host port.

2010/9/29 Neil Benn <neil.benn@gmail.com>


I am assuming you work at TI or for them indirectly Koen?

I would expect better answers coming from someone in support besides
"it works for me"

It appears he was asking a specific question here below

which is also a problem because i dont know which file to get (Im
talking about version)

— On Tue, 9/28/10, Koen Kooi koen@beagleboard.org wrote:



> From: Koen Kooi koen@beagleboard.org
> Subject: Re: [beagleboard] REV B6 USB OTG as HOST problem
> To: beagleboard@googlegroups.com
> Date: Tuesday, September 28, 2010, 8:11 AM
>
> I plug in the proper otg cable and it just works when using angstrom on my b6 boards
>
> On Tue, Sep 28, 2010 at 4:39 AM, Luis Cavazos <filoteo@gmail.com> wrote:
>
> > Hi I been reading over and over looking on how to solve his but i
> > havent found the answer.
> >
> > SO basically i have the same problem a lot of people had trying to
> > configure the USB OTG port of the beagle as Host.
> >
> > I already have shorttened pin 4 and 5 so you can rule that out.
> >
> > i already tried the
> > 1.- modprobe g_zero
> > 2.-echo host > /sys/devices/platform/musb_hdrc/mode
> >
> > whitout any succes. i always get a FATAL: error inserting g_zero <path
> > 2.6.32> Device or resource busy…
> >
> > Yes im using a power supply to power up the beagle.
> > and yes im using a hub with power supply so it doesnt takes power from
> > the beagle.
> >
> > I check pin 1 and for some reason its always 0 (Showing that
> > definitively the beagle is not changing from OTG to host).
> >
> > Im using the latest Angstrom from http://www.angstrom-distribution.org/demo/beagleboard/
> > which is also a problem because i dont know which file to get (Im
> > talking about version) my beagle is up and running i can vnc through
> > OTG and has internet access. However the next step in my project was
> > to add some peripherals.
> >
> > Im pretty sure that the problem is related to the version of Angstrom
> > or Uimage or boot or ine of those files there. However without knowing
> > which one should I pick i wouldnt change it jut like that. SO PLEASE
> > is someone has a REV B6 and it made his OTG work as HOST tell me the
> > SECRET!!!
> >
> > –
> > You received this message because you are subscribed to the Google Groups “Beagle Board” group.
> > To post to this group, send email to beagleboard@googlegroups.com.
> > To unsubscribe from this group, send email to beagleboard+unsubscribe@googlegroups.com.
> > For more options, visit this group at http://groups.google.com/group/beagleboard?hl=en.
>
> –
> You received this message because you are subscribed to the Google Groups “Beagle Board” group.
> To post to this group, send email to beagleboard@googlegroups.com.
> To unsubscribe from this group, send email to beagleboard+unsubscribe@googlegroups.com.
> For more options, visit this group at http://groups.google.com/group/beagleboard?hl=en.

|

Kristoffer Sk�ien wrote:

Hi! I have the exact same problem om my revC4 BB.

�ngstr�m worked fine, but with Debian and Ubuntu i only get the
"install" screen on my monitor that tells me to select install
language..
- Of course without any keyboard detected I am stuck.

"�ngstr�m worked fine", sounds good to me, no?

from? http://www.angstrom-distribution.org/demo/beagleboard/

use 2.6.32

Everything else is ancient...

(and the multiple file names is just a thing Angstrom/Bitbake does..)

Regards,

Modprobe g_zero doesn’t make sense here, as that is not a host driver. Don’t do that. Plug in a keyboard instead. Please provide the full kernel log.