Rev C4 - USB Hub and devices not recognized

Just bought BeagleBoard Rev C4 and hooked up an USB Hub with a
keyboard and mouse. The USB hub is connected to the USB host
connection on the board. I have a SD card with Android flashed on it.
I am able to boot the board without any problem. But the keyboard and
mouse is not recognized. Are there any known issues with Rev C4 with

My hub, keyboard, and mouse work just fine on my Rev C4.


Gerald Coley escreveu:

My hub, keyboard, and mouse work just fine on my Rev C4.

Same here. Have you tried to use a powered USB hub?



Thanks for the response. Obviously this issue is happening only to me.
I wanted to do a thorough board-level validation for the peripherals,
but could not do that for the reasons below. Perhaps, I can use some
help on that:

I tried to follow the instructions here:
for doing board validation starting from preparing MMC card. I noticed
that, for C4, I have to copy the files from a different source (http:// This resource does
not have all the eight files listed in the instructions. Some
confusion there.

Also, the pre-flashed SD card that I got from the vendor boots upto
Android. After booting I tried to validate the USB Host port as
described in Step 7 of the instruction page (under 'Continue Board
Validation'). But, I could not find the 'evtest' command to use in
'evtest /dev/input/event2'. I tried to this even at the BB boot level,
without Android. Is there any other way we can validate the USB Host

I would plug in a USB thumb drive directly into the connector, mount it, and the read and write from it. You also need to make sure that your HUB is a USB2.0 HUB. You cna then repeat the test with the Thumbdrive plugged into the HUB.

Oh, and one more thing. You need to make sure that you use the correct UBoot or the USB circuitry will not be powered on. You need to check with the person that sold you the SD card to make sure it has the updated UBoot on it. That was the big change on the Rev C4.


I don’t know about C4, but at C2 USB mouse works only if it was connected to HUB BEFORE power-up. If I remove a mouse and insert it back - it does not work

2010/3/9 Sarigama <>

Yes, I am using a externally powered UDB hub.

Yes, I am using a externally powered UDB hub.

Does the kernel recognize the HUB? Can you post the messages printed
when the kernel boots?

OK. I will do the test and post the results. Also, can you answer my
question about the right files that need to be copied to the SD card,
if I want to prepare it myself? The board validation instrcutions say
that, for Rev C4, different set of files need to be copied, but it is
not clear what those files are. Thanks.

Use the ones that are stated on the C4 page. You can use the ones on the C3 page, but you must use the UBoot from the C4 page.

To be clear, the C3 files will work on C4 as long as you use the C4 designated UBoot file. The C4 files will work as well. The C4 files are what are used in the factory for testing of the boards.


Yes, this should be written somewhere on the board or inside the Box
in BIG LETTERS :slight_smile:

We have finally added a note on our page because we got many phone

I am trying to get the information fixed, but I don’t seem to be making any progress. But, I will keep trying!


I have still not tested with the right U-boot file yet. I will do this
this week and post my experience. BTW, my USB hub has an ethernet port
that I am planning to use for internet connectivity from the board. I
assume that, if the USB problem goes away with the latest U-boot file,
it will also take care of the network connectivity from the USB hub.
Or, will there be any surprises?

I replaced the u-boot.bin file from the link mentioned in the C4 page
and tried to start the board. All I saw was my DVD-I screen turns full
orange in color and booting sborted. Here is the message on the screen
(below). When I put back the u-boot file provided by my Beagleboard
vendor, there is no problem in booting and and Android screen comes,
but no USB support. Looks like simply replacing the C4 version of
uboot.bin file may not work, unless I miss something else.

Texas Instruments X-Loader 1.4.2 (Feb 19 2009 - 12:01:24)
Reading boot sector
Loading u-boot.bin from mmc

U-Boot 2009.11-rc1 (Jan 08 2010 - 21:19:52)

OMAP3530-GP ES3.1, CPU-OPP2 L3-165MHz
OMAP3 Beagle board + LPDDR/NAND
I2C: ready
DRAM: 256 MB
NAND: 256 MiB
*** Warning - bad CRC or NAND, using default environment

In: serial
Out: serial
Err: serial
Board revision C4
Die ID #33e6002400000000040365fa17005009
Hit any key to stop autoboot: 0
mmc1 is available
reading boot.scr

** Unable to read "boot.scr" from mmc 0:1 **
reading uImage

** Unable to read "uImage" from mmc 0:1 **
Booting from nand ...

NAND read: device 0 offset 0x280000, size 0x400000
4194304 bytes read: OK
Wrong Image Format for bootm command
ERROR: can't get kernel image!

Well, the message says that the scripts are not on the SD card. It says there is no UImage file on the card. You need to copy all the files onto the SD card from the validation page. Read the instructions carefully where it tells you to rename the files.


Voila! It works after I copied the normal.scr and boot.scr files also.
Now the mouse and keyboard connected to my USB that is connected to
the USB Host on the BeagleBoard is recognized. I will be more than
happy to offer my advise when someone with similar situation posts.

Now, I need to make sure my BeagleBoard can have internet connection.
Now my next step is to figure out why the ethernet port connected to
the USB Hub is not working. I assumed that all I have to do is to hook
up the ethernet port on the USB Hub to my router and it will
automatically get the LAN IP address. Any tips on how to troubleshoot