Revision C4 - No boot message and USR0, USR1, and PMU not lighting up

Hello everyone,

I've just received my BeagleBoard Revision C4, hooked it up per the
user manual, powered it on but saw no boot message in terminal using
minicom or Screen with none of the USR0, USR1, and PMU LEDS not
turning on - only PWR.

Is this a sign my board is defective or a sign that I've hooked
something up incorrectly?

Thank you,

This does sound like you may have a possible issue. I would try making an SD card and forcing the card to boot from it by holding the User button down.

  1. It could also be a case of you trying to power the board over the USB OTG port and the PC not delivering enough power to boot the board.
  2. Having the wrong voltage on the DC supply, over 5V.


Thanks for the help, Gerald. I've verified that it is receiving the
correct voltage. I will send it back in for a new BeagleBoard. Could
this have been caused by human error on my part or is it simply a
defective board? I would just like to avoid making the same mistake if
I made any.

Thank you,

There are several things that could have been done, like erasing the NAND. If you try the SD card process, assuming you format the card correctly and write the files in the right order, that should take care of the issue if the NAND was erased.

You can send the board in for repair or try to send it back to the distributor for a refund. If it is damaged in some way, it might be better to get it repaired in order to figure out what happend… Where did you buy the board from?


How does someone erase the NAND? I'm not sure if I did or not, but
I'll probably try seeing if using an SD would fix it.

I bought the board from SparkFun - I should be able to get a refund or
exchange it.


What I don’t know is if the card was factory fresh or maybe recycled in some way. I have never seen that done, but it is a physical possibility. If you were to issue the erase command, that could cause it. Or it could just be corrupted to the point the processor is hanging. If it were erased cleanly you should get something out of the serial port and the only LED on would be power. I think you need to create the SD card as mentioned and see how far you cna get with that process.


Thanks for your help Gerald. I know I found it before but I can't seem
to find the SD card creation process anymore - do you have a link to
the guide?


I've just tried the SD card boot process, but the same result occurs.
Guess it's time to return it - thanks for your help, Gerald.

If there is an issue like this with your board, it will be the first i have seen in over 20,000 shipped. I recommend that you request an RMA instead of returning it.


Just thought i would suggest this, but, are you sure you have the right serial connections. I used a cable that didn’t swap RX/TX and I thought mine was broken too. After I looked a little more, I found the right cable, and it worked fine.

i have 2 boards, and they work fine for first 2 weeks,but now both
have the same problem…what should i do ?? :frowning: :frowning:

I suggest that you start a seperate discussion for your issue. It is possible that while you may have the same symptoms, it may be a different issue.


Hi Gerald,

Thanks for your help previously. I went ahead and returned the
BeagleBoard and received another BeagleBoard from SparkFun. However,
this one is doing the same thing leading me to think that something is
wrong with how I am setting up the BeagleBoard.

I took an SD card, formatted it to FAT32 using Disk Utility on Mac OS
X, copied the necessary files to it in the required order (following
the instructions at,
put it into the BeagleBoard, pressed and held the USR button while
putting in the power supply, and that's it. Do I need to have the
serial connection in order for the BeagleBoard to work as outlined in
the BeagleBoard guide?

Looking back on the URL for setting up the SD card, it seems to be for
an old revision whereas I have the C4 revision - however, I can't seem
to find the C4 revision guide for setting up the SD card that has
unbroken links to the files.


Actually, could a power supply that was insufficient or too much cause
the BeagleBoard to only show a rapidly blinking PWR led?

You MUST use the format utility we tell you to use or the board will not boot. Dn not use a MAC. to format the card.


I second that, OSX adds too many bogus files like .Trashes and -spotlight-V100 for the ROM to handle.

While I totally agree that a person having problems should try to follow the
"official" procedure to the item, I as well will say, that I really don't
believe that having special files on a MMC card will cause any trouble. It
will more likely cause you trouble having a "wrong" number of
cylinders/track or something in this category...

Best regards

Just a brief hello from a new user:

Got my Rev C4 board running Angstrom (not the demo test version but the proper version) off a 1gb SD card.
Looking to see how many days I can run my beagle off a 12 Watt Solar panel/leisure battery combo.


I have some experience that contradicts this. I had a working SD card
with MLO, u-boot and uImage on it. In the course testing some
alternate kernels I renamed my uImage file to something that wasn't
simple 8.3 but required use of the long filename extensions. After
this my BB would no longer boot from that SD card. Reformatting the
boot partition and re-installing the same MLO, u-boot and uImage with
simple 8.3 names fixed it.

FWIW this is on a C2 BB - I've seen it suggested that newer revisions
may not have this issue, but I have no direct experience of this.


Just to be clear, there was a valid kernel named 'uImage' on the boot
partition - it was the presence of other non 8.3 files on the
partition that prevented xloader from accessing the filesystem.