Rogers LTE Rocket stick with Beaglebone

I am trying to make my Rogers LTE Rocket Stick work with Beagelbone.

So far:

  1. I know the stick works because I tested it with Windows Xp and it works like a charm.

  2. I also tested in with a recent version of Ubuntu on my desk top machine. It also works perfectly.

  3. Here is the result of:


wwan0 Link encap:Ethernet HWaddr 46:D0:8F:4E:01:07


RX packets:0 errors:0 dropped:0 overruns:0 frame:0

TX packets:0 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:1000

RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

  1. root@beaglebone:~# lsusb

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Bus 001 Device 003: ID 1199:68a3 Sierra Wireless, Inc.

Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

From the Sierra Wireless web site:

We suggest adding the following lines in the interface file located:

/etc/network/interfaces using any text editor

auto wwan0

iface wwan0 inet dhcp

  1. When I tried that from the console I got:

root@beaglebone:~# iface wwan0 inet dhcp

-sh: iface: command not found

root@beaglebone:~# iwconfig wwan0 inet dhcp

iwconfig: unknown command “inet”


  1. Apparently this is the APN setting for Rogers, however the driver has changed and no longer supports “AT” commands.

Rogers LTE: at+cgdcont=1,”IP”,”lteinternet.apn “

Anyone have any ideas ??