root partition on sd card (mmcblk0p2) never mounts

I've tried partitioning new sd cards with a vfat first partition for
boot (x-loader, etc...) and a second partition of type ext3 for a
Beagleboard xM A3 to hold the root fs using fdisk, script,
and gparted, all with no success after the initial loading and run of
the kernel. I've also tried writing various images directly to a
number of sd cards, some SDHC and some not. The mmcblkp1 partition is
vfat and can be read during boot, but it seems that after the uImage
is read and run the board loses access to the sd card and can't read
the partition table.

The last image I've tried was the maverick 10.10 image found here: and I've tried
multiple Angstrom builds with the exact same result:
Starts to boot (x-loader/u-boot), loads uImage, starts running the
kernel, finds the sd card but can't find the partition table so it
can't locate the root partition, and hangs. When the sd card is moved
back to the PC I clearly see the two partitions (1: vfat,lba,boot; 2:
ext3), the standard directories, and files.

My assumption to date was that I've been missing something in the sd
card partition setup but I haven't, at least according to the text and
utilities on the web.

This all starts with a good kernel boot sequence (console) that starts
showing problems after the USB device discovery:

First the board discovers the card...
  mmcblk0: mmc0:b300 SU04G 3.69 GiB (rw)
  mmcblk0: Cannot read partition table
  mmcblk0: Available partitions:
  mmcblk0: VFS: Cannot open root device "mmcblk0p2" or unknown-

My assumption was that it couldn't read the partition table, as
stated, but even sd cards prepared from images boot to a command
prompt but cannot see or mount the sd card. I've tried creating new
devices in dev (mknod /dev/mmcblk0p1 b 179 1 and mknod /dev/mmcblk0p2
b 179 2) after booting to the ramdisk but with no change. Once at a
command prompt running fdisk /dev/mmcblk0 just freezes the board.

The Maverick 10.10 boot sequence says it can't mount mmcblk0p2 and
details some common reasons, none of which seem to be the cause. The
board is running from the recommended DC 'wall-wart' supply. I get the
same error messages as above with the Angstrom kernels.

Of interest was the output from the Maverick image as it still
couldn't see or mount the sd card partitions but it did fall into a
slow loop trying to mount the mmcblk0 device, something like:

..INFO: mmcqd : 118 blocked for more than 120 seconds
..mmcqd D 118 <some memory address> <another memory address>

After which it appears to reschedule the device probes which I'm
assuming is the slow loop.

It looks like the linux kernel is resetting the I/O lines to the sd
card during boot. Do the xM A3 cards have sd card problems? Is there a
sd card driver problem with some xM boards?

I'm not new to embedded devices or linux and this has me beat. Any


I was suspect of the sd card pins and was ohming out the pcb traces to
the sd card pins when I saw a small hair like short between the sd
card side of two pins on the sd card mount pads using a magnifier and
light. This was way too small to be seen with the naked eye. Once
scratched away the board saw the partition table, the partitions, and
booted into Angstrom. I'm surprised the short didn't fall off in
handling. Odd that it could read the sd card at all.

I'm up and running and that's what counts.