rproc bind/unbind problem

Hello everyone,

I have a problem with rproc PRU driver in Linux. My setup is beaglebone black and official debian image bone-debian-9.3-iot-armhf-2018-01-28-4gb.img.xz.

The problem is simple. I cannot find bind/unbind in the rproc driver.

Here is the console ouptup:

prusa_pro:/# echo 4a334000.pru0 > /sys/bus/platform/drivers/pru-rproc/unbind
-sh: /sys/bus/platform/drivers/pru-rproc/unbind: Permission denied

I’m kind of new in Linux so I guess I’m missing something simple. I tried to load rpmsg firmware example from TI and it worked OK. But still no bind/unbind in /sys/bus/platform/drivers/pru-rproc/.

Thanks for any advice.


sudo bash

echo 4a334000.pru0 > /sys/bus/platform/drivers/pru-rproc/unbind


unbind/bind doesn’t work in the latest kernel versions. Instead you can use this to restart remoteproc and load the firmware:
echo ‘stop’>/sys/class/remoteproc/remoteproc1/state
echo ‘start’>/sys/class/remoteproc/remoteproc1/state


From the command line, this seems to work for me:

sudo sh -c “echo ‘4a334000.pru0’ > /sys/bus/platform/drivers/pru-rproc/unbind”

I hope it works for you, too.

– Will