rs-232 communications over ttyO2 (not console)

Hello

I have been trolling the web trying to workout how to use the built-in
ttyO2 to perform rs-232 communications. I wish to use the built-in
rs-232 transceiver.
I have found how to disable ttyO2 as a console by deleting the console
arguement out of uEnv.txt and removed /etc/init/ttyO2.conf. So now the
built-in rs-232 port doesn't present itself as a console.

The following is what I deleted:

Sudo rm /etc/init/ttyO2.conf

delete the following out of uEnv.txt from the boot partition of the sd
card.
- console=ttyO2,115200n8
- optargs=console=tty0
- console=${console} ${optargs}

However I can't seem to go any further. I have been trying to set the
port as 9600 8-n-1 with no flow control from the command line on my
dvi monitor. However I can't seem to get stty or setserial to perform
any commands on ttyO2.
I was wonder if anyone had a bash script or knew commands that have
worked on the beagleboard xm to setup ttyO2 into a known configuration
and check the ports configuration.

My understanding is that I once I can configure the port I should be
able to simply type on the commandline to send data out the port:
Echo "test" > /dev/ttyO2

Any help would be appreciated.
Thankyou
Troy

I use ttyO2 for rs232 communication, but I did not delete the ttyO2.conf file. Only I changed the start on option in this file. I think you shall not delete it.

2012/2/14 Troy Boswell <troy.boswell1@gmail.com>

Thankyou very much its working now.

Here are my steps.

Mount the sd card into you development machine (I use Ubuntu).

My target OS for the beagleboard is also ubuntu.

delete the following out of uEnv.txt from the boot partition of the sd
card.
- console=ttyO2,115200n8
- optargs=console=tty0
- console=${console} ${optargs}

Modify the /etc/init/ttyO2.conf file in rootfs.
open the file manager as root, for me this is:
# sudo nautilus

as directed by ahmet delete the first line in ttyO2.conf which is:
start on stopped rc RUNLEVEL=[2345]

Now unmount the boot and rootfs partitions and insert into you BB_xm
(target device) and power on.

Once you are booted investigate the baud rate of the serial port.

# stty -F /dev/ttyO2

I get:
speed 9600 baud; line = 0;
-brkint -imaxbel

Now test the port, set up a serial port on an external machine using
whatever works for you, hyperterminal, minicom or gtkterm. Set it to:
9600, 8-n-1, no flow control.

Now send some text to the serial port from the bb_xm and you should
receive it on the external machine.

# echo "test" > /dev/ttyO2

Once received set the bb_xm ttyO2 port to receive on the commandline:
# cat /dev/ttyO2

Now send data from the external machine and it should print on the
BB_XM commandline.

That should be it, for me ttyO2 is setup and tested for use.

Troy

In my case it was /etc/init/serial.conf and NOT the ttyO2.conf fileā€¦