Hello ,
I am using Beagle Board black. I want to use RS485 by UART4 to read data from modbus resister.
currently i am using "BB-UART4-RS485-00A0.dtbo" for reference i put schemettic photo .

RS485_TX → p9.13
GPIO_48_RS485_EN → p9.27

i think pin configration is proper.

problem :- As i need to send data “GPIO_48_RS485_EN” should be high , and to receive data it should low . Making High and Low that task need to handle by kernal automatically but it not do automatically i want that making high/low this task should be handle by kernal . i want solution for this .

By making menual high/low by user data is send and received proparly that i checked.(That mean hardware ckt is working proparly)

Any one have solution than please provide me.

Have you checked out RS-485 RTS drive RS-485 Tx-enable from Kernel - #16 by MichaelS or other posts on the forum for people being stuck with RS485? Without looking at more documentation, I don’t know if the RTS signal is what is appropriate there. I am at RISC-V Summit this week, but could look at it with the Beagle cape with RS485 next week.

Did a bit more searching on using our COMMS cape with RS485. Found this thread GHI Comms cape - no overlay file in /lib/firmware

Hi. I got this all working with help from the group.If I can help you, let me know

1 Like

thank you for responce now it’s work.