rtcwake with rtc

Hi, I want to use the comand rtcwake to sleep and wake up the beaglebone blue. I have seen that bb-blue has a RTC0 configurated for wakeup but this is not a real rtc.

I connect a real rtc (DS1307) on a I2C , the system rename it as RTC1 and I have two rtc → RTC0 and RTC1.

When I call rtcwake on RTC0, works but not awake because not a real rtc and time is set to 00:00:00 and not count. And when I call rtwake on RTC1 the system say that RTC1 is not configurated for system wakeup.

On beaglebone black same command and same RTC detects on RTC0 and works fine.

I can not disable RTC0 and I can not configure RTC1 for wakeup the system.

Can somebody help me?


Look at these overlay examples:


The aliases field will allow you to specify which device gets to be: RTC0:

aliases {
rtc0 = "/ocp/i2c@4802a000/mcp7940x@68";
rtc1 = "/ocp/rtc@44e3e000";