rtl8192cu always rfkilled on Debian Jessie (systemd?)


I have been trying for weeks in vain to get rfkill to unblock (soft) (and leave unblocked) wlan0, an rtl8192cu.

relevant software versions:
systemd 215-17+deb8u4rcnee1~bpo80+20160313+1
rfkill 0.5-1

root@beaglebone:/var/lib/systemd/rfkill# uname -a
Linux beaglebone 4.1.15-ti-rt-r40 #1 SMP PREEMPT RT Thu Jan 7 23:32:08 UTC 2016 armv7l GNU/Linux

I’ve tried systemd’s boot time parameter systemd.restore_state=1, and modified /var/lib/systemd/rfkill/platform-musb-hdrc.1.auto-usb-0:1:1.0:phy0, with both a 0, and a 1 in the file. Regardless of the contents of platform-musb-hdrc.1.auto-usb-0:1:1.0:phy0, wlan0 was softblocked after systemd was through.

Examining kernel-parameters.txt, I next went for: rfkill.default_state=1 rfkill.master_switch_mode=0
wlan0 was still soft-blocked

I next added a pre-up line, “pre-up rfkill unblock wifi”, to /etc/network/interfaces, which brought the interface up, and then rfkill shut it down ~7 seconds later, and soft-blocked it.

I would greatly appreciate any help you guys might have in getting rfkill to enable wifi on boot. There was a thread back in December of 2015, which recommended network-manager, but I prefer connmand, and as rcn-ee pointed out in that thread, there are issues with network manager, and the ethernet port.


been fighting connman with this on bluetooth... Make sure connman settings
under WiFi has "Enable=true". i had been looking under rfkill/systemd the
whole time..




Did you uncomment the auto wlan0 line in the /etc/network/interfaces ? I dit , and got the same error, can’t get wlan0 working after reboot,

here is what I found in a book :exploring beaglebone black

if you uncomment the auto wlan0 line in the /etc/network/interfaces file, then the wireless interface will start on boot. You should not make this change until the adapter is fully working.