RTL8192CU Driver Problem


I would like to integrate Wi-Fi in my Beagleboard xM, with the use of Belkin N150 Surf WiFi Dongle.

However, I have noticed that rtl8192cu driver which is preloaded along with Ubuntu 12.04, is not working (dmesg gives me the result “wlan0: link is not ready” while I can find networks with “iwlist scan”).

I have checked this:
but I don’t think I would like to build a new kernel and replace the already existed one.

So, I would like to ask you if there is any tested 8192cu driver module I could download, capable of working with this dongle in kernel 3.2.

System specifications:
Beagleboard-xM Rev C
OS: Ubuntu 12.04
Linux Kernel: 3.2.24-x14

Thank you for your time.

For the xM, v3.2.x is now considered legacy, care to retest with
v3.6.x to see if your wifi now works?

For 12.04/armhf do:

wget http://rcn-ee.net/deb/precise-armhf/v3.6.5-x3/install-me.sh
/bin/bash install-me.sh


Hi Robert,

Thanks for your advice, but do you think compiling the driver would work for 3.2.x?


No idea, but if you want to spend the time trying it go right ahead...

But personally, I'd try a newer mainline in the off-chance that
someone fixed the bug, before relying on a Company X's source drop...


Thank you for your answers.

Robert, I installed kernel 3.6.5-x3, according to your advice, but the problem still exists. dmesg gives me the result:

“IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready”

In addition, when I run “ifup wlan0”, I have the result:

ioctl[SIOCSIWENCODEEXT]: Invalid argument
ioctl[SIOCSIWENCODEEXT]: Invalid argument

Do you have any idea on overcoming this problem?

Thank you for your time.

Hi Vasilis,

I am also working on the wifi driver.

Is your ethX interface turned down?

My laptop has the issue of “ioctl[SIOCSIWENCODEEXT]: Invalid argument”

But wlan0 works still. I don’t know whether this is a problem or not. What are your settings for the board?


Hello and thank you for your interest,

Yes I have turned down the eth0 interface through /etc/network/interfaces file. However, I won’t have WiFi available. The only changes I have applied are the following:

  1. In the /etc/network/interfaces, I have entered:
auto wlan0
iface wlan0 inet static
wpa-conf /etc/wpa_supplicant.conf
wpa-driver wext

  1. wpa_passphrase > /etc/wpa_supplicant.conf

Thanks again.

I would like to ask one more question: Could it be possible to find a dongle that works with my Beagleboard xM out-of-the-box, without any special driver configuration?

I have a Netgear N150 dongle (WNA1100). It worked once and then died. I think the problem might be power supply. Have you tried to use a powered usb hub?

I haven’t tried that, but I don’t think that this is the case… How did you make it work? Did you use the same rtl8192cu driver? Have you tested anything else since that?

I did not use any customised driver. The lsmod indicates the driver is ath9k_htc, not rtl8192cu. I searched for compatible dongles here:http://wireless.kernel.org/en/users/Drivers

And then I just specify the configuration in the /etc/network/interfaces

By the way, usb hub power is not the problem, I tried a usb hub w.o power today. It works just fine.

I see… I can’t really figure out what’s happening. I just want to get my Beagle xM connected without the need of an Ethernet cable. If anyone else has already tried something different, please let us know.