Running Assembly routines from C code on the DSP


I want to benchmark some algorithms running under OMAP's DSP. For that
end, I got some Assembly routines at TI's website [1], and wrote code
to run it with dspbridge. When I try to create the DSP node on the ARM
side of the application, it fails. I'm using this code [2] from felipec as an
example, but changed the memcpy call to the Assembly call (and changed
everything else that was needed for it to work). dummy_arm.c fails at
the function create_node.

I noted it only fails when using Assembly routine calls. I wrote C
functions instead and everything works. Can it be something with the
Assembly linking? There are no messages about undefined symbols or
something like that.

I tried to run the application twice. At the first run, got only the
error messages, but when I tried to run it again, more cryptic
messages appeared to scare me. Here [3] they are.

Have you ever had problems like this? What can I do to solve it?

Thanks in advance!
-- João