Same Exact Image booting on BeagleBone Black but doing NOTHING on PocketBeagle


Due to corporate requirements we are modifying a Stretch Image from Changes include:

  • Several capes have been added.
  • Different packages have been pre-installed.
  • Configurations.

So far, we were working with BBB without any problems. Image ran fine and without problems.

Last week, we started to play with the PocketBeagle. We first used our image and surprisingly it didn’t DO ANYTHING.

By anything I mean that even connected to serial, it reports nothing.

Same image, on same card boots perfectly fine on a BBB but in the PocketBeagle NOTHING.

It doesn’t even display the uboot loader message.

First I thought that was due to the fact that we were using custom capes. Then because of the version of the kernel (4.9.82)… But a standalone image from (with that same kernel) just boots fine.

I even tried replacing the entire boot directory… by the one of a working image (with the same kernel of course)… but nothing.

All those changes always report the same behaviour:

They work flawlessly on the Beaglebone Black… But the PocketBeagle does NOTHING.

Any idea?

Thanks in advance,


Which image (aka the date identifer)?

Regards, Debian Image 2018-03-05
Kernel is vmlinuz-4.9.82-ti-r102

Well, had this issue parked on the desk for a few weeks.

Turns out, that when creating the image, we weren’t copying MBO and u-boot to the 4MB at the start.

Hence it loaded perfectly from BBB (it has them on the EMMC) but failed miserably in the PocketBeagel (doesn’t have them).

Taking a base image from and getting those first 4MB by dd and copying them to our image (first 4MB), solved the problem.