screen blank in 10 miute.How to avoid ?

I have in BBB bbxm-ubuntu-14.04.1-console-armhf-2014-10-29-2gb.img .For desktop OpenBox is installed.
Everything is working fine except screen gets blanked out exact after 10minutes.
I have tried many commands like :
xset s 0 0 dpms force on
setterm -blank 0 -powersave off -powerdown 0
in .profile / .bashrc etc…
but nothing is working .
Please help

cat /home/user/.xsessionrc


xset -dpms
xset s off


Or in the xorg.conf :

Section “Device”
Identifier “Builtin Default fbdev Device 0”
Driver “modesetting”
Option “SWCursor” “true”
Option “StandbyTime” “0”
Option “SuspendTime” “0”
Option “BlankTime” “0”

None of the solutions are working.I dont know where i am lacking.Ok let me give you more details about the systems.
I am in a process to make a linux kiosk.Wher only one GUI will run , so to directly go to gui i have modified the system as follows:

  1. Installed OpenBox.
  2. edited /etc/iit/tty1.conf
  3. commented line: #exec /sbin/getty -8 38400 tty1
  4. added line: exec /usr/bin/login -f -p ubuntu < /dev/tty1 > /dev/tty1 >2&1
  5. added line: exec startx
  6. ~/.config/openbox/autostart : MyGUI
    Thats all.All the system is working absolutely flawless , except this blanking screen problem.Please Help

odd, as:

cat /home/user/.xsessionrc


xset -dpms
xset s off

Is what we use in the offical Debian image to make sure the
lcd/hdmi never shut's off..


after creating xsession i did xset q
Screen Saver:
prefer blanking: yes allow exposures: yes
Standby: 600 Suspend: 600
DPMS is Enabled
Monitor is On

as per @Mickae1 i tried to create xorg.conf
but gives me error : No Device to configure
i create by hand , but no use.
Please Hep

Can you google ? I’ll give you a hint, its a kernel startup option . . .

one more thing i want to put in your notice, that although i have made auto login for use ‘ubuntu’.
exec /usr/bin/login -f -p ubuntu < /dev/tty1 > /dev/tty1 >2&1
but when it ends up in openbox ,it logs in as root. Why it is so?
Please help

@Wiliam yeah sure …

How can i edit my existing uEnv.txt file to put a boot parameter:
i think this will solve the problem.

you’re looking for /boot/uEnv.txt I think is the current location on the latest images, and for a line that looks something like . . .

cmdline=quiet init=/lib/systemd/systemd

And then you do . . .

cmdline=quiet init=/lib/systemd/systemd consolbank=0

I think parameters are space separated, but it is either space or comma separated. I do not know everything from memory, and since I’m away from my dev systems for a few more days . . . Anyway, you can probably check on the internet somewhere. To verify, you can do . . .

cat /proc/cmdline ( again going from memory . . . ) to make sure your modification took.

Pretty much all kernel startup options can be used similarly. So for instance if you wanted to disable ipv6 and the console blanking at boot . . .

cmdline=quiet consolbank=0 ipv6.disable=1

This would of course use init ( SYSV )for the init daemon as no path to systemd was specified. And then disable console blanking and then disable ipv6 system wide I believe.

Anyway, I’m not an expert with Linux boot params, but I have used both consolbank=0 ipv6.disable=1 , and they do work. Also, some params are platform / hardware specific, so may not work on all hardware platforms.

shouldnt it be consoleblank ???

ok…i got it …let me summarise my problem:
i was having screensaver on in my BBB , at every 10minutes interval, which was not getting off.Now i got it off by
by adding a shell script to /etc/xdg/openbox/autostart:


xset dpms 0 0 0
xset -dpms
xset s noblank
xset s noexpose
xset s 0 0
xset s off

@Robert , But i dont know why this same script is not working in /home/user/.xsessionrc
I m closing this topic and marking as “No Action Needed”

Much easier to have this line in /boot/uEnv.txt

cmdline=quiet consoleblank=0

This then works whether you are using X-Windows or a terminal via ssh or the serial port. I was finding that after installing the SGX drivers and running the OGLES2ChameleonMan demo, the screen would blank after a short while. Not anymore.

@Dekay I will use both as a safe side.bcos this one is code burden.