Second UART on BB-XM


I'm working on connecting my beagleboard to another device over UART.
However, that device will only work with TTL logic.
So my question is: What is the voltage level of the second UART on the
expansion header of a BeagleBoard XM?
Also, with Angstrom, do I need to change some PINMUX settings to use
I'm using a console-only build from Narcissus.


The Beagleboard-xM system reference manual states (

“CAUTION: The voltage levels on the expansion header are 1.8V. Exposure of these signals to a higher voltage will result in damage to the board and a voiding of the warranty.”

So, you will need a voltage level translator. This one might work:

Thanks Jake for the quick reply!
I bought a USB to TTL serial converter suspecting this.
The idea was to get something that will allow me to use a PC or the

The problem is, its a CP2102 chip which doesn't work with Angstrom.
I tried compiling the drivers given here:

I get the following error while building directly at my BeagleBoard:
make -C /lib/modules/2.6.32/build -I /media/sda1/cp210x-3.1.0/cp210x
M=/media/sda1/cp210x-3.1.0/cp210x modules
make: *** /lib/modules/2.6.32/build: No such file or directory. Stop.
make: *** [modules] Error 2

Any ideas?

Why don't you just rebuild the kernel with?


Support for the CP210x usb-serial devices has been mainline for awhile..


Thanks Robert. I'll try that.


I tried rebuilding the kernel.

1. First, I followed the steps here:
and built an un-modified kernel.

2. Uncommented the CONFIG_USB_SERIAL_CP210X line like:

3. Did a clean:
MACHINE=beagleboard ./ clean

4. Copied the uImage file to the boot partition, made a backup of the
firmware and modules folders in /lib, deleted them and extracted the
modules archive there.

I got a new shiny 3.0 kernel but still no CP210x support! There's no /
dev/ttyUSB0 upon inserting the device.
Any pointers on what I did wrong?


Finally got round to working on this again.
I copied the vmlinux file to /boot and it works now.
I wonder why this is not part of the deploy folder.