Select timeout error when running video streaming code


I am testing an opencv video capture code on my BBB (running Debian Wheezy: Linux beaglebone 3.8.13-bone79 #1 SMP Tue Oct 13 20:44:55 UTC 2015 armv7l GNU/Linux) but getting a select timeout error everytime i run the program. Now i am behind schedule of my final year Iris recognition system Project. (In case you want to know why i am going through this video capture code, it is for tracking the eyes then capture an image that will be processed to obtain an IrisCode.)

I installed opencv 3.0.0 following instructions on , but had to turn off ffmpeg (suggested on one of the forums: ) after obtaining a compilation errors but firstly i had compiled ffmpeg from source.

Below is the Video_Capturing code i tested with;

import numpy as np
import cv2

cap = cv2.VideoCapture(0)


Capture frame-by-frame

ret, frame =

Our operations on the frame come here

gray = cv2.cvtColor(frame, cv2.COLOR_BGR2GRAY)

Display the resulting frame

if cv2.waitKey(1) & 0xFF == ord(‘q’):

When everything done, release the capture


After running the code i am obtaining the following information (Note: The frame is only opening when i run the python script in LXTerminal accessed through tightvnc. It is failing to run through ssh);

oot@beaglebone:~/Project/Testing# python

(process:1488): Gtk-WARNING **: Locale not supported by C library.
Using the fallback ‘C’ locale.
Xlib: extension “RANDR” missing on display “:1”.
select timeout
select timeout
select timeout
select timeout
^Cselect timeout
Traceback (most recent call last):
File “”, line 8, in
ret, frame =

I’m stuck i need your help.

Is anyone out there to assist? I’m stuck

I finally got a solution to the problem. This might help someone out there facing the same problem. Rather i would say i avoided the problem and not really solved the problem. I was able to get a video stream from the preinstalled Debian Distro. OpenCV 3.0.0 seems to have some issues. It is the one that keeps on giving the “select timeout error”. I thought it was a v4l driver problem but then i had to compile v4l from source to get the latest update but still obtaining the same error.

What i don’t really get is is that, is it a BBB hardware or some driver problem? Why i ask that question is that, the code can run well in an Ubuntu 14.04 PC with installed OpenCV 14.04 LTS.

I hope someone can try it and if there is a solution, i have my eyes open to see it because i would like to use some SIFT packages in OpenCV 3.0.0 on my BBB.