Set priority of network interfaces wlan0 rather than eth0

Hi guys,

I am pretty new using a BBB, and I am trying to use it with two network interfaces, one, wlan0 to get internet through usb wifi dongle, two a local connection via eth0 to another network.

I configured the /etc/network/interfaces wlan0 as a inet with dhcp, eth0 with inet… static, an every works fine, because of I ping to the local network and it gaves me a anwer, I ping google and I have internet.

Since booting I start with my networks fine, but The REAL PROBLEM is after a few seconds, when the BBB put eth0 as a default interface, so my internet is down (wlan0) , so I lose every contact with the world.

I try to do ifdown, ifup, but the internet is gone, only when I unpluged the RJ45 (eth0), I get internet again. BUT I want to work with the two networks at the same time.

How I set up forever my wlan0 as a default connection (interface), because I use IFMETRIC, so in my file /etc/network/interfaces I use metric 1 (wlan0), metric 10 (eth0), but the BBB does not care any metric.

with route -n the system mounts a iface with eth0 and metric 0 , and the other parameters on Zero, too.

Any help??


William, the link you recommended uses /etc/network/interfaces for the setup; doesn’t that require having NetworkManager enabled whereas I think Jessie is currently using connman and comes without NetworkManager installed? (this is a question, not a statement) Felipe, which network manager are you using? Finally, I thought that “metrics” was built into the kernel? I’ve seen that the kernel (or something else I am unaware of) is doing a lot of configuration especially wrt to usb0 and sometimes assigning IP addresses and then redirecting them via which effectively sends them to nowhere? For example (third line below left over after hand configuring using “ip” - I could get rid of it, but it doesn’t do any harm; I would like to understand the process causing it; I’ve also seen a lot of re-directed routing coming from outside the router? especially when using usb0?)

ip route show
default via dev wlan2 dev wlan2 proto kernel scope link src via dev lo metric 303

You may need to decide how to configure your networks and then do it by hand using “ip” perhaps similar to the link William suggested but possibly not using /etc/network/interfaces unless you have decided to use NetworkManager. I found a good link on networking (albeit a bit dated) is by Martin Brown.On Monday, December 7, 2015 at 3:19:06 AM UTC-5, William Hermans wrote: