setting up VNC for ubuntu

I am trying to set up VNC from a WIn7 PC into the BBB I am running ubuntu on the BBB.

on the terminal:

ubuntu@arm:~$ sudo apt-get install x11vnc vnc-java

ubuntu@arm:~$ x11vnc -storepasswd (wrote my password)

ubuntu@arm:~$ x11vnc -foreever -usepw

Password written to: /home/ubuntu/.vnc/passwd
22/11/2013 18:22:19 x11vnc version: 0.9.13 lastmod: 2011-08-10 pid: 1926
22/11/2013 18:22:19 XOpenDisplay("") failed.
22/11/2013 18:22:19 Trying again with XAUTHLOCALHOSTNAME=localhost …
22/11/2013 18:22:19
22/11/2013 18:22:19 *** XOpenDisplay failed. No -display or DISPLAY.
22/11/2013 18:22:19 *** Trying “:0” in 4 seconds. Press Ctrl-C to abort.
22/11/2013 18:22:19 *** 1 2 3 4
22/11/2013 18:22:23 XOpenDisplay(":0") failed.
22/11/2013 18:22:23 Trying again with XAUTHLOCALHOSTNAME=localhost …
22/11/2013 18:22:23 XOpenDisplay(":0") failed.
22/11/2013 18:22:23 Trying again with unset XAUTHLOCALHOSTNAME …
22/11/2013 18:22:23

22/11/2013 18:22:23 ***************************************
22/11/2013 18:22:23 *** XOpenDisplay failed (:0)

*** x11vnc was unable to open the X DISPLAY: “:0”, it cannot continue.
*** There may be “Xlib:” error messages above with details about the failure.

Some tips and guidelines:

** An X server (the one you wish to view) must be running before x11vnc is
started: x11vnc does not start the X server. (however, see the -create
option if that is what you really want).

** You must use -display , -OR- set and export your $DISPLAY
environment variable to refer to the display of the desired X server.

  • Usually the display is simply “:0” (in fact x11vnc uses this if you forget
    to specify it), but in some multi-user situations it could be “:1”, “:2”,
    or even “:137”. Ask your administrator or a guru if you are having
    difficulty determining what your X DISPLAY is.

** Next, you need to have sufficient permissions (Xauthority)
to connect to the X DISPLAY. Here are some Tips:

  • Often, you just need to run x11vnc as the user logged into the X session.
    So make sure to be that user when you type x11vnc.
  • Being root is usually not enough because the incorrect MIT-MAGIC-COOKIE
    file may be accessed. The cookie file contains the secret key that
    allows x11vnc to connect to the desired X DISPLAY.
  • You can explicitly indicate which MIT-MAGIC-COOKIE file should be used
    by the -auth option, e.g.:
    x11vnc -auth /home/someuser/.Xauthority -display :0
    x11vnc -auth /tmp/.gdmzndVlR -display :0
    you must have read permission for the auth file.
    See also ‘-auth guess’ and ‘-findauth’ discussed below.

** If NO ONE is logged into an X session yet, but there is a greeter login
program like “gdm”, “kdm”, “xdm”, or “dtlogin” running, you will need
to find and use the raw display manager MIT-MAGIC-COOKIE file.
Some examples for various display managers:

gdm: -auth /var/gdm/:0.Xauth
-auth /var/lib/gdm/:0.Xauth
kdm: -auth /var/lib/kdm/A:0-crWk72
-auth /var/run/xauth/A:0-crWk72
xdm: -auth /var/lib/xdm/authdir/authfiles/A:0-XQvaJk
dtlogin: -auth /var/dt/A:0-UgaaXa

Sometimes the command “ps wwwwaux | grep auth” can reveal the file location.

Starting with x11vnc 0.9.9 you can have it try to guess by using:

-auth guess

(see also the x11vnc -findauth option.)

Only root will have read permission for the file, and so x11vnc must be run
as root (or copy it). The random characters in the filenames will of course
change and the directory the cookie file resides in is system dependent.

On the Windows PC I installed RealVNC and open it to and it keeps giving me “Connection Refused 10061”

Cannot find a good solution online.

Any help would be appreciated


You need to specify the port number too. e.g.

If that doesnt work then i have no idea.

I tried with port 22 nothing worked …hmmm


If I am not mistaken it needs to be port 5900.


Thanks for the response. I tried

I am using real VNC to connect and x11vnc on the host.

Is there a way to look at the BBB and figure out which ports it has open?



Do I need to do anything to the firewall on the host??

Its a Win 7 laptop



you can disable the windows firewall temporarily to test. If the firewall is the cause then you should be able to create a firewall rule.

Just keep in mind that this is not a Windows support group, so if you need help in doing that, google would be your best friend.

It doesn't seem that your x11vnc is actually starting from this error
message. Do you have X running on the BBB ? If you have X running, do this:

ps ax | fgrep -- -auth
  /usr/bin/X :0 vt7 -nr -nolisten tcp -auth /var/run/xauth/A:0-Hu3Jac

See that '-auth /var/run/xauth/A:0-Hu3Jac' ? You will have something
similar, use that like this, replacing where appropriate:

sudo x11vnc -auth -auth /var/run/xauth/A:0-Hu3Jac

You can usually go without the '-auth' as long you run x11vnc as the
user that started X.


- --

one too many -auth, pass just one:

sudo x11vnc -auth /var/run/xauth/A:0-Hu3Jac

- --