software appeard to destroy usb driver

Hi,

I have a RevB beagle board which appears I have destroyed the usb port
on (making it fairly useless to me) I don't think it was my fault.
Maybe someone can think of something I can do to fix it or what might
have gone wrong.

I loaded a very recent kernel (2.6.30) I pulled from git. The kernel
did not boot and instead panics. I was then told that there was a
patch needed since this kernel configured regulators incorrectly.. but
the version in git now has this patch, so I unfortunately got it at
just the wrong time.

I tried to boot an older kernel (2.6.29) which I had great success
with (much better usb support than older kernels) But now the usb
does not work at all. I have probed the pins on the usb connector,
and instead of 5v, I read 0.3v (very bad) The beagle board is still
supplied with 5v, and it reads 5v. The board appears to work fine
(over serial console) and it draws the same amount of current as
before, but usb does not work at all.

Any ideas?

Thanks,
Sean

I don’t see how SW could damage a board. If you have .3V, it may be due to the power actually being turned off on the USB port or some other event caused damage to the board. I would take it back to factory condition and run the diagnostics as are described in the Rev B7 System Reference Manual to determine the state of the HW.

http://code.google.com/p/beagleboard/wiki/BeagleBoardDiagnostics

Gerald

I tried with the kernel from the link on the Diagnostics page. usb
works again, so I guess I didn't damage any hardware.

The annoying thing is the 2.6.29 kernel which was working so well
(only kernel I ever got wifi to work with) now it can't do usb at all
anymore.. I can't explain why the same exact kernel would work in the
past but now, the usb vbus pin is about 0.3 volts and usb doesn't work
anymore, doesn't matter if I power the board off.. I'm not sure how
it could remember this and behave differently. I guess I have to try
other kernels to try to find one which can do usb and wifi.

Thanks,
Sean

Sean:

I assume you are trying to use the USB OTG port in host mode. My
experience with a BeagleBoard B4 is that the USB Vbus (pin 1 of USB
OTG connector or at R5) is approx 5V when BeagleBoard thinks it's a
host and approx 0V when BeagleBoard thinks its a device (and OTG port
is connected to a hub's upstream port). Maybe you lost the short
between USB OTG pins 4 and 5 that tells Linux to set OTG to host mode?

Hope this helps.

John