SPI Ports on Beaglebone Blue not working


I have a problem with the SPI interface on my beaglebone blue. The pins seems to be held by the “eqep” dts overlay:

[    0.001592] timer_probe: no matching timers found
[    0.731556] wkup_m3_ipc 44e11324.wkup_m3_ipc: could not get rproc handle
[    0.974526] pinctrl-single 44e10800.pinmux: pin **PIN102 already requested by 48300180.eqep**; cannot claim for ocp:P9_30_pinmux
[    0.985922] pinctrl-single 44e10800.pinmux: pin-102 (ocp:P9_30_pinmux) status -22
[    0.993509] pinctrl-single 44e10800.pinmux: could not request pin 102 (PIN102) from group pinmux_P9_30_spi_pin  on device pinctrl-single
[    1.005952] bone-pinmux-helper ocp:P9_30_pinmux: Error applying setting, reverse things back
[    1.093014] omap_voltage_late_init: Voltage driver support not added
[    1.099997] PM: Cannot get wkup_m3_ipc handle

What is the correct way to disable a uboot dts overlay ? I dont need the encoders in my project anyway, so that’s no problem.
Linux and UBOOT, are up to date, GitHub - beagleboard/BeagleBoard-DeviceTrees: Linux kernel device trees and device tree overlays for BeagleBoard.org open hardware single board computers and add-on boards. have been rebuild and installed.

There are some hints on the net, but i can’t get that stupid overlay removed by any measure…

I have tried this here: https://forum.beagleboard.org/t/problems-with-spi-on-bb-blue/2216, → doesnt work.

I have also tried to disable the 4 eqep DTBs in uEnv.txt → doesnt work.

Anyone with a good idea what to try next… ?


Please provide the image you are using w/ cat /etc/dogtag and the kernel used w/ uname -r.

Also, do you have a recent update/upgrade that took place b/t it working and not working?

One more thing I can think about is the /dev/ directory.

Are your SPIDEV0.0 - SPIDEV1.1 listed in /dev/ or /dev/bone/?


P.S. Oh! There is a newer git.beagleboard.org repo full of ideas and DTS. The BeagleBoard-DeviceTrees is located there in that repo. too.


I finally got it working:
After an kernel update from 4.19.94-ti-r42 to -r73 with “update_kernel.sh” the error disappeared.

Before that I tried a build of the “BeagleBoard-DeviceTrees” from GIT, but using that leads to a non booting -r42 kernel.
The system hangs without any errormessage right after starting the kernel.

With the -r73 kernel now working, I will not do further experiments on that front…



1 Like