spidev again (for a noob)

hello list,

apologies for a naive question, but i have been trying for too long
now to get spidev working on my beaglebone, including much perusal of
list archives and other resources.

early on, i came across a thread on this group[1], containing a patch
to board-am335xevm.c[2], and a link to some debug builds[3].

i tried installing the uImage and the modules from the debug build, it
boots but nothing spi-like shows up in /dev/

i also got openembedded installed, and after many tribulations i can
build and boot a vanilla kernel+angstrom. bitbake doesn't seem to
think that the patch posted in [1] is compatible with the sources
resulting from "bitbake virtual/kernel -c configure", so i tried
making my own version of that patch on top of those sources. this
didn't work either.

my attempted patch is here:
and the resulting sourcefile is here:
(it looks a little strange to me... what's that flash on spi1? hm)

it also occurred to me that perhaps i don't even know how to tell if
this is working. there is nothing like /dev/spi* showing up on the
beaglebone after boot, but maybe i'm missing a step ("modprobe spidev"
or similar?)

a related question: there has been some discussion on this list of
rolling some sort of generic spidev behavior into the standard
beaglbone OS. that would be nice, i think. any ideas if this will
happen soonish?

any help from the experts would be much appreciated! embedded linux is
strange new territory to me, and i am clearly a bit lost. thanks for

ezra b

[1] https://groups.google.com/group/beagleboard/browse_thread/thread/776a4ca8ca3c06e/a3833cd8a473ce94?lnk=gst&q=spidev#a3833cd8a473ce94


[3] http://www.beagleboard.org/~share/beaglebone-debug-20120110/

hoping to get some help on this as well. anyone?