SSH Connection refused on BBG

I have a Beaglebone Green dismantled from a machine made by others. I would like to access its contents and edit the code.
I tried to connect it via USB but the connection timed out on
Then I connected it to my router via ethernet and an external 5V supply, my router assigned a static IP address to it. I tried to connect it via SSH (PuTTY) on port 22 but prompted Network error: Connection refused.
How should I connect to the BBG properly?

Some more information:

  • I am using Windows
  • I have obtained login credentials from the manufacturer
  • I have another brand new BBG which works normally and I could access

Any help would be appreciated, thanks.

Can you connect to the serial port ? Assuming the serial console hasn’t been disabled that will get you connected.

If the board has previously been used for something else there is no telling what has been configured/disabled on it. SSH may be disabled, or maybe running on a different port. User names might not be what you expect, so trying to login as debian fails.

Assuming you don’t need to keep any data, you could just download the latest image and re-flash the board. Or you could boot from an SD card and then mount the EMMC and read off any data.

Assuming the old install is on the eMMC… You could flash a new image onto a microSD, boot-up with the microSD, and mount the eMMC… Then ‘inspect’ the eMMC, possibly reconfiguring ssh to allow you access, or really anything…


Now I have booted it from microSD, how should I read the eMMC?

I found an article about extracting BBB eMMC contents to microSD card:

Is there a way to do so on BBG? If I could successfully replicate the content and flash it on another BBG then my work should be considered successful.

What’s your end goal… “Access” the eMMC’s contents as-is, or boot your own stuff?

If you just want to access the eMMC, just mount the partition and change/edit/grab the files you want…


The ultimate goal is to replicate the BBG. I haven’t worked with Beaglebone or eMMC before so I’m quite confused.

I checked there is only one eMMC partition so I’ve done the following:

root@beaglebone:/# mkdir temp
root@beaglebone:/# mount /dev/mmcblk1p1 temp/
root@beaglebone:/# ls temp/
bbb-uEnv.txt  boot  etc   ID.txt  lost+found  mnt           opt   root  sbin  sys  usr
bin           dev   home  lib     media       nfs-uEnv.txt  proc  run   srv   tmp  var

Does that mean I have mounted the eMMC partition to the microSD? What should be the next step to replicate it on another BBG?

Yeap, you’ve now mounted the eMMC in ./temp/ so go ahead and make your changes to that drive that you wish.

You find the ‘encrypted’ password under:


One of the tricks to removing it, just replace it with blank…

root_password=$(cat ./temp/etc/shadow | grep root | awk -F ':' '{print $2}')
sed -i -e 's:'$root_password'::g' ./temp/etc/shadow


So does that mean the scripts and autorun configurations are also in ./temp/?
I forgot to mention, the BBG was supposed to run by external commands from the machine. The end-user has nothing to do with logging in to the system.

I’ve come across this but for BBB: linux - Duplicating identical BeagleBone Black setups - Stack Overflow
Is there a similar way that I could copy the original image to the new board, or I could just overwrite the new board with the mounted content on my microSD?

Thanks for your kind help.

You mounted it there…

root@beaglebone:/# mount /dev/mmcblk1p1 temp/

So the whole eMMC is mounted under ./temp/, as you mounted it there…

I’d go for the dd option if you want to backup/restore it, as it’s someone else’s custom image…


Thanks for the suggestion.
I used ‘dd’ and cloned the image of mmcblk1 to the microSD successfully.
However the new BBG seems to have smaller eMMC size, I checked by fdisk -l and found it was exactly 80 MiB smaller… So the image restoration failed on the new board.
I tried to ‘dd’ the image to another blank microSD, but seems it wasn’t bootable and nothing happens.
Did I do anything wrong to the image?

OK I’m just here to close the topic.
The last solution is that I copied the .img of the eMMC and flashed it on another microSD.
Everything resolved now, thanks for all the help.