SSH, ping over IPv6 only, not IPv4

Hello All,

I’m running “Linux beaglebone 3.8.13-bone80 #1 SMP Wed Jun 15 17:03:55 UTC 2016 armv7l GNU/Linux” on a Rev C BBB.
Yes, this is an old version, but have to remain on this due to the application, and have the latest eMMC(5.1) support(Thank you Robert!).

I had a query a while back about disabling wicd breaks networking here:https://groups.google.com/forum/#!searchin/beagleboard/wicd|sort:date/beagleboard/jxJzB6MlqeA/I3eHMpBnBAAJ
However, I found out that IPv6 works, so does beaglebone.local via putty or ping.

Now, I feel I may have broken some networking file when disabling wicd that caused this.
The following services are disabled:

sudo update-rc.d apache2 disable
sudo update-rc.d wicd disable
sudo systemctl disable cloud9.service
sudo update-rc.d saned disable
sudo update-rc.d lightdm disable
sudo systemctl stop graphical.target

sudo update-rc.d alsa-utils disable
sudo systemctl disable bonescript-autorun.service
sudo update-rc.d cpufrequtils disable
sudo update-rc.d hdparm disable
sudo update-rc.d loadcpufreq disable
sudo systemctl disable wpa_supplicant.service
sudo systemctl disable bonescript.socket
sudo systemctl disable cloud9.socket
sudo systemctl disable graphical.target

This is my /etc/network/interfaces file:

This file describes the network interfaces available on your system

and how to activate them. For more information, see interfaces(5).

The loopback network interface

auto lo
iface lo inet loopback

The primary network interface

#auto eth0
#iface eth0 inet dhcp

Example to keep MAC address between reboots

#hwaddress ether DE:AD:BE:EF:CA:FE

The secondary network interface

#auto eth1
#iface eth1 inet dhcp

WiFi use: → connmanctl

Ethernet/RNDIS gadget (g_ether)

Used by: /opt/scripts/boot/autoconfigure_usb0.sh

iface usb0 inet static
address 192.168.7.2
netmask 255.255.255.252
network 192.168.7.0
gateway 192.168.7.1

ifconfig:

debian@beaglebone:~$ ifconfig
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

usb0 Link encap:Ethernet HWaddr 04:a3:16:f5:25:10
inet addr:192.168.7.2 Bcast:192.168.7.3 Mask:255.255.255.252
inet6 addr: fe80::6a3:16ff:fef5:2510/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:479 errors:0 dropped:0 overruns:0 frame:0
TX packets:75 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:61361 (59.9 KiB) TX bytes:20074 (19.6 KiB)

Does anyone have any suggestions to get IPv4 back.

Thank you,
-Gerry