Start QT Application on bootup on Beaglebone Black

Below is picture of the display on bootup. Expected display output is overwritten by Angstrom screen

Expected Display output

The expected display output briefly appears but is overwritten by the Angstrom text based image. But occasionally the expected display appears. Then the dynamic widgets update the screen but the static information is not visible. The issues appears to be timing, and if the BBB can be forced to start the QT application after complete bootup of BBB that would suffices the current needs.

Application is been started as a service. Below is the content of the service file


Description=QTAccelerometer GUI

ExecStart=/home/root/projects/qt-projects/QTAccelerometer -qws



Below are the other options tried without success





Thank you in advance


you should switch to debian, you will have more help from the Debian community … I’ve a BBB under debian which start QT at bootup !


enable autologin in Angstrom

add to the end of /etc/profile this line`

/home/root/projects/qt-projects/QTAccelerometer -qws&


You’ve accomplished more than I’ve managed to do. Could you suggest some references I could check so I can figure out what silly mistakes I’m making?

Cheers, Tim


Please look the this stackoverflow questions and response

Start QT Application on bootup on an Embedded Linux Device (Beaglebone Black)

Based on this input I was able to resolve the issue. I will post my end solution in due course.

Thanks! That’s more grist for my slowly grinding mental mill…

Dear Micka,
could you please tell us more about your BBB starting QT at bootup ?
A description of your configuration would be very helpful

best regards,