Starting VNC at boot in debian

Im working with the 6-17 machinekit image on on my BBB running the xenomai kernel and I am having a hell of a time getting things to autostart, specifically x11vnc.

Ive been able to get this to work with raspberry pi and in ubuntu, but no matter what I have tried or what tutuorial I follow I cant seem to get anything to autostart on the BBB.

Is anyone using a VNC server that they can give me the script and setup process they are using? The directions I followed most recently are these and still no luck:

There are several ways of doing this, but here is my preferred way (as root):

-create a password file using “x11vnc -storepasswd <password_file>” and provide your password, then chmod 600 <password_file> to avoid anyone reading it but root,

-create the following in /etc/init/x11vnc.conf (make sure you replace the “<…>”, from the script details below, with the correct information):

start on login-session-start
x11vnc -xkb -noxrecord -noxfixes -noxdamage -repeat -display :0 -auth/var/run/lightdm/root/:0 -forever -shared -bg -o /var/log/x11vnc.log -rfbauth<password_file_plus_path> -rfbport 5900 -allow <ip_address>
end script

Now let’s see some of the options used above (and it has a lot of them):

-xkb will allow better clipboard interactions in my experience,

-repeat is allowing keyboard repeating keys (most annoying thing when it doesn’t work),

-forever means even if you disconnect from your session, x11vnc will still be alive,

-shared means several users may be connected at the same time (use this only if you plan to connect multiple users simultaneously to it),

-allow enables to restrict the machines that will be able to connect to vnc, remember, vnc is an open door to your machine (I removed this for my linux PC).

Reboot. You should be able to connect on the default port 5900 after that.

Still having issues. I followed some guides specific to LDXE this weekend but still no luck. Anyone?

I dont use Debian but on Arch once I setup a systemd service file it starts on boot as expected for me. Been doing this for well over a year now without issue.