Still working to remote debug.......

Well, I started some days ago by putting a Linux box together. I’ve lived my life on Windows so this is all new to me. I’ve gotten all the way to connecting from Eclipse and compiling ‘Hello World’. I’m using the gcc-arm-linux-gnueabihf-4.18.2014.07-1_linux cross compiler. Eclipse puts the executable on the beagleboneB but I get "Error during file upload
and three: Operation failed: file system input or output error’s.
When I ssh into the BBB and try to run it I get a ‘-sh: ./HelloWorld: No such file or directory’. It is there. objdump the file on the Debian side and I think it looks ok, lots of debug info. The file is 66824 bytes; seems kind of big.

But it has been a long road to get here, I figured I would just ask if someone has an idea why it won’t run. I’m so close!

Thanks, Dan.

Well first of all GCC is not yet at version 4.18, and last time I checked it was still only 2013, so please pay a little more attention when you give the facts and it might be easier to help you…
Is that the Linaro toolchain you are using?

Have you tried this?

Worked for me some time ago.

The solution from Fernando Rocha worked for me.

It seems that on the target is no support for the hardware floating point unit because of missing runtime libraries.

HI, Jesper, Fernando,
I did see that. But it was not the distribution I used. The box I was using was old and fell apart. I’ll be back in three weeks and put a newer Ubuntu box together and use that tool chain. Sounds like the right one.
Best, Dan.

Just follow the procedure from Derek Malloy’s video on youtube.