strange power issue


I have been working on the beaglebone since 1 year now and I had no issue since some days ago.
I am using the BBB with a motherboard which among other thing is powering the BBB .
The issue happens when I am first plugging the mini USB to a PC then plug the power from the motherboard. The symptoms are that the i2c busses 1 and 2 are timeouting when I am doing i2c request.Bus 0 is fine.
If I do a i2cdetect -y -r 1 it takes about 2 secs poling each adress . The other symptom is that sometimes I loose ethernet over usb connection .
I tried several BBB (rev B and C) with several motherboards and issue is still there.
The other strange thing is that for now It happens only on 1 PC. Here again I tried different USB port with same behavior.
I have read lots of messages from this group without finding anything close to my issue. The only similar issue I have found is here :
I tried the latest release debian 2015-03-01 and althought it seemed more stable than mine which is from april 2014 I am still experiencing the issue.
So any idea or similar experience is welcomed !


Sounds like you have it fairly well isolated, down to a specific PC. So not exactly BBB related but . . .

How old is this PC in question ? I’ve read about PCs with garbage power regulation ( on the motherboard obviously ) exhibiting flaky behavior as such. Another “idea” that comes to mind is that the driver software could be in a bad state for some reason. Bad install, hardware drivers that do not play nicely with libusb, or even potentially . . . a virus. It could even be an old Windows install going crazy ( assuming windows of course ).

There is a tool which for the life of me I can not remember the name of that can monitor the USB protocol while connected. Wireshark can do this too I think. So this may be one way to troubleshoot software issues. As for hardware issues, I’m not sure exactly how to go about troubleshooting. . .

Thanks for answering .
The PC is quite new about 2 years old with windows 7 . I have also seen this issue once on another PC .
To sum it up , on this pc when I plug USB then external power , it sometimes acts like no external power is applied. (I have the same symptoms when powering only using USB but this is normal) .
Seems that there is some code on the bootloader which changes some registers on the TPS65217 depending on which current source is applied I don t know if it is related.
It is not a big issue but I’d like to understand why such behaviour.