Suspected HW issue with Beaglebone Black

Hi All,

I am trying to rule out SW issues with my BBB (HW Rev A5C) running Angstrom. First I am going to give a bit of background on when the issues started and then provide dumps of crashed as seen via UART.

  1. BBB was working fine for quite some time.

  2. Then I tried to switch from wired ethernet to wireless by plugging in UWN200 ( while BBB was powered by DC adapter.

  3. My SSH over wired Ethernet froze.

  4. I removed the UWN200 and rebooted a device but could not longer connect via SSH with wired ethernet

  5. Connecting via USB (client) I could not get network connection to either. As I realized later I did not even have usb0 listed when running ifconfig

  6. At this point I connected via UART

  7. I could see that the kernel was crashing with NULL pointer dereference Oops

  8. Every few restarts it would get past this oops

  9. I shutdown BBB and looked to upgrade to latest Angstrom a few days later, thinking maybe I am just a lucky one to hit a real bug in the kernel

  10. I downloaded the following image into SD card

  11. BBB was booted from SD by holding the boot button.

  12. Flashing process was problematic, it took a few reboots (about) from SD card for eMMC flashing to complete (4 solid LEDs) without kernel Oopsing

  • One of the Oopses was odd as it was for “invalid instruction”

To me this feels like a HW problem due to failures manifesting themselves in different ways. Segfaults in the apps, NULL pointer dereferences in the kernel, Soft CPU lockups. But I would like to rule out a user error.

Few observations:

  • I have run mtest from uboot without any errors being detected

  • Same for memtester

  • Pressing rest button does not always reboot the device. Sometimes holding power button down is the only way to reboot the BBB. But sometimes it works just fine.

  • For a few reboots accessing BBB via HTTP would causes kernel Oopses. Trying it out just now and it worked just fine

The below is done post flashing to the latest angstrom:

Any suggestions on what I can do to narrow down the root cause of the issue would be greatly appreciated.

Thank you,


Try with a different software package, e.g. (I’d highly recommend using this over Angstrom in any case) If you have similar problems it might help point to a HW issue.

Finally had a day to install Debian with updated u-boot and 3.13.1 kernel (custom compiled from, no issues so far.

Thank you,