Suspend/Resume with the Beaglebone (am335x-pm-firmware.bin/Robert Nelson kernel)


the previous problem that the firmware blob does not get loaded by
the kernel has been solved (see previous thread on this): I didnt
followed the linked instructions carefully enough.

Now the firmware gets loaded and all entries under /sys, which were
previously missed are there.

It is possible to suspend-to-ram the board.

But thats it.

There is no come back, no resume.

I have to reboot/powercycle.

Is it possible at all to completly suspend/resume the board?

What version of the firmware blob should I use?

Does anyone on this list succeeded in a completly suspend AND
resumeing the Beaglebone?

Best regards,

I'm not sure this feature has ever worked properly. However I have noticed that support for Suspend/Resume was recently posted to the linux-omap mailing list [1] for integration to mainline so I expect it won't be too long now before support is there!

If you're really keen you could try out the patches.