testing a beaglebone black with 4DCape-70T :: factory image versus Jessie Debian 2015-1-27

Hi

With the factory flashed eMMC image , the 4DCape-70T was detected on boot up, and a calibration screen was launched before the GUI. This calibration application included a countdown timer , shown using a animated color circle in the middle of the screen. Everything worked nicely on a quick test.

Using http://elinux.org/Beagleboard:BeagleBoneBlack_Debian, I used a 8Gb uSD card to flash the jessie debian testing image from 2015-1-27 to get access to qtcreator (for qt 5) via apt-get. [ https://rcn-ee.net/rootfs/bb.org/testing/2015-01-27/lxqt-4gb/BBB-eMMC-flasher-debian-jessie-lxqt-4gb-armhf-2015-01-27-4gb.img.xz ]

The 4DCape-70T didnt work on boot up, but required adding in a dtb=am335x-boneblack-4dcape-70t.dtb line in /boot/uEnv.txt and rebooting. The LCD cape works for display, but the calibration application wasn’t installed.
I did install a “libts-bin” from wheezy , and can run ts_calibrate, but this isn’t the same version (or maybe not even the same program) as above. It looked partially the same, but for instance had no timer, counting down. I presume that the timer was added, because it was added into the boot-up sequence. However, even with the version of ts_calibrate it still is very badly calibrated, with the boundary areas inaccessible, and has ghost input / skipping the cursor around the screen.

Any hints how to get back to the calibration program via the factory flashed version of Debian? I can offer to port it to Debian testing BBB image. :smiley:

Less important, since i can patch around it, but what changed between the (presumably) Wheezy image and jessie image, so that the cape isn’t automatically available anymore?

Cheers cuz,

Andy

Hi

With the factory flashed eMMC image , the 4DCape-70T was detected on boot
up, and a calibration screen was launched before the GUI. This calibration
application included a countdown timer , shown using a animated color circle
in the middle of the screen. Everything worked nicely on a quick test.

Using http://elinux.org/Beagleboard:BeagleBoneBlack_Debian, I used a 8Gb uSD
card to flash the jessie debian testing image from 2015-1-27 to get access
to qtcreator (for qt 5) via apt-get. [
https://rcn-ee.net/rootfs/bb.org/testing/2015-01-27/lxqt-4gb/BBB-eMMC-flasher-debian-jessie-lxqt-4gb-armhf-2015-01-27-4gb.img.xz
]

The 4DCape-70T didnt work on boot up, but required adding in a
dtb=am335x-boneblack-4dcape-70t.dtb line in /boot/uEnv.txt and rebooting.
The LCD cape works for display, but the calibration application wasn't
installed.
I did install a "libts-bin" from wheezy , and can run ts_calibrate, but this
isn't the same version (or maybe not even the same program) as above. It
looked partially the same, but for instance had no timer, counting down. I
presume that the timer was added, because it was added into the boot-up
sequence. However, even with the version of ts_calibrate it still is very
badly calibrated, with the boundary areas inaccessible, and has ghost input
/ skipping the cursor around the screen.

Don't use libts-bin, use xinput-calbrator (which is already installed)..

However i haven't wired it up the lightdm "yet"

Priority right now is to ship the last "wheezy" stable release..
Before i focus entirely on jessie.

Any hints how to get back to the calibration program via the factory flashed
version of Debian? I can offer to port it to Debian testing BBB image. :smiley:

Less important, since i can patch around it, but what changed between the
(presumably) Wheezy image and jessie image, so that the cape isn't
automatically available anymore?

Well, downgrade to:

sudo apt-get install linux-image-3.8.13-bone70

and your cape will be autodetected..

Regards,

Hi

With the factory flashed eMMC image , the 4DCape-70T was detected on boot
up, and a calibration screen was launched before the GUI. This calibration
application included a countdown timer , shown using a animated color circle
in the middle of the screen. Everything worked nicely on a quick test.

Using http://elinux.org/Beagleboard:BeagleBoneBlack_Debian, I used a 8Gb uSD
card to flash the jessie debian testing image from 2015-1-27 to get access
to qtcreator (for qt 5) via apt-get. [
https://rcn-ee.net/rootfs/bb.org/testing/2015-01-27/lxqt-4gb/BBB-eMMC-flasher-debian-jessie-lxqt-4gb-armhf-2015-01-27-4gb.img.xz
]

The 4DCape-70T didnt work on boot up, but required adding in a
dtb=am335x-boneblack-4dcape-70t.dtb line in /boot/uEnv.txt and rebooting.
The LCD cape works for display, but the calibration application wasn’t
installed.
I did install a “libts-bin” from wheezy , and can run ts_calibrate, but this
isn’t the same version (or maybe not even the same program) as above. It
looked partially the same, but for instance had no timer, counting down. I
presume that the timer was added, because it was added into the boot-up
sequence. However, even with the version of ts_calibrate it still is very
badly calibrated, with the boundary areas inaccessible, and has ghost input
/ skipping the cursor around the screen.

Don’t use libts-bin, use xinput-calbrator (which is already installed)…

However i haven’t wired it up the lightdm “yet”

Priority right now is to ship the last “wheezy” stable release…
Before i focus entirely on jessie.

Ok, yes xinput_calibrator works. Thanks mate.

Any hints how to get back to the calibration program via the factory flashed
version of Debian? I can offer to port it to Debian testing BBB image. :smiley:

Less important, since i can patch around it, but what changed between the
(presumably) Wheezy image and jessie image, so that the cape isn’t
automatically available anymore?

Well, downgrade to:

sudo apt-get install linux-image-3.8.13-bone70

and your cape will be autodetected…

Regards,


Robert Nelson
http://www.rcn-ee.com/

I am sticking to 3.14.30-ti-r47 and testing repo , thanks :slight_smile: Everything is working nicely for QT5 development. qtcreator 3.2.1 / qt5.3.2 installed via apt-get all work.
QT Creator wasn’t auto configured properly, but it was possible to get it to work manually configuring the ‘kit’ via (Tools->Options) setting the qt versions and compilers.

Very nice work to all involved!

Andy