Three GPIO pins During Source Calling/BBB


I have a Bullseye image with kernel 5.10.x and I want to control three GPIO pins almost in succession.

There are breaks in between the usage of the pins but I am having difficulty trying to make three pins work. Is this a known limitation or are the builds with gpio groups along with root groups not allowed to use the debian user with the debian groups?

I thought I figured this idea out in the past. I have been severely misunderstood currently or I am misunderstanding things with how Linux on the images is processing my direct commands.

So,, will show a list of commands for such an issue that I am currently seeking to solve.

Are other people having issues with the GPIO pins on the BBB or is it just me?

Does changing the user:group for specific files ever amount to anything when building source for particular peripherals on the BBB? The reason I am trying to change ownership of files and set permissions to groups is to control a three GPIO usage driver.

The driver says, “Three GPIO pins will make your driver move motors,” or at least it comes close to stating that fact.

So, I have tried w/ sysfs and gpiod. My current group is gpio while the user is root. I can change things obviously but nothing has worked to this day from about a month ago on my system from images and kernels.

If you have any input or ideas I have not tried, please jump in. Rations accepted!


P.S. I will try again with updated user:group settings and see if there was something I missed. In the meantime, I implore you to help me in this endeavor of building a workin’ driver model…

I will most likely be back quickly to see if someone has promoted any findings in their images/kernels with user:group ideas and permissions.


So. I have configured the GPIO pins in question for debian:gpio and I am in the gpio groups file.

I have set my file to debian:gpio user and groups file. I still cannot control anything so far. I know, I am new and things have changed a bit, some stuff and I willing to keep going further in my findings.


P.S. Oh!

-rwxr-xr-x 1 debian gpio   1523 Aug 31 08:27

See, I would think that if my file is the same as the GPIOs I am using, I would then be able to use them. I am incorrect but I will keep on searchin’ for the reasoning.



My PSU is busted. That is the update. It creates the voltage I need but not the amperage for the motor I am using. I think I got gipped. So, no issue. I am goin’ to get another PSU to test and hopefully this time the total wattage will be satisfactory. I believe right now this is not a BBB issue but a wattage issue for the driver to the motor(s) in question.