Trouble Booting Beagleboard xM Rev A2 With Ubuntu

I am getting the following output when I attempt to boot Ubuntu from a Micro SDHC card, the PNY brand, 4 Gb class 4:

I am getting the following output when I attempt to boot Ubuntu from a Micro
SDHC card, the PNY brand, 4 Gb class 4:

-----------------------------------------------------------------------------
Welcome to minicom 2.4

OPTIONS: I18n
Compiled on Oct 6 2010, 03:31:42.
Port /dev/ttyUSB0

Press CTRL-A Z for help on special keys

60
(above is: 3 strange characters that appear to be all '0001', followed by
the number 60, followed by 6 more strange characters that appear to be
'0013', '0002', '0001', '0012', '0015', '0001')

--------------------------------------------------------------------------------

I followed directions from here:

http://elinux.org/BeagleBoardUbuntu

I used the setup_sdcard.sh script that is referenced on the web page,
however I wanted the very latest version so I cloned Robert Nelson's git
repository using `git clone` and then used that setup_sdcard.sh script
version. I used this command:

Hi Bob,

This with Fedora 14/15 correct?

I've actually been working on getting the script to work better with
fedora today, however we just ran into an issue with fdisk
(utils-linux-ng) changing in 2.18 (which f14/15 have), and i haven't
quite figured out how to correctly specify the first fat partition..
Hence the xM isn't finding the first partition on bootup right now..

./setup_sdcard.sh --mmc /dev/sdb --uboot beagle

Yeah, that's the correct line..

with pre 2.18 (so 2.16.x) we could specify the first fat partition with:

sudo fdisk -H 255 -S 63 /dev/sdX << END
n
p
1
1 <- first sector
+64M
a
1
t
e
p
w
END

In 2.18, we need specify "-c=dos" since it defaults to non dos
compatibility mode (which forces the first sector to 2048), with the
dos option, it moves back to sector '63' but as you just tried that
doesn't work.. awesome huh? :wink:

Regards,

Hi Bob,

This with Fedora 14/15 correct?

Hi Robert,

Yes I'm using Fedora 14. I still have Fedora 13 on the other hard drive though. Maybe I can use that to help with this...or install 13 as a virtual machine on 14.

I've actually been working on getting the script to work better with
fedora today, however we just ran into an issue with fdisk
(utils-linux-ng) changing in 2.18 (which f14/15 have), and i haven't
quite figured out how to correctly specify the first fat partition..
Hence the xM isn't finding the first partition on bootup right now..

That explains the mystery. I am learning and yes, enjoying the lessons. So from what you are saying here we need to solve the fdisk issue in Fedora 14.

with pre 2.18 (so 2.16.x) we could specify the first fat partition with:

sudo fdisk -H 255 -S 63 /dev/sdX<< END
n
p
1
1<- first sector
+64M
a
1
t
e
p
w
END

In 2.18, we need specify "-c=dos" since it defaults to non dos
compatibility mode (which forces the first sector to 2048), with the
dos option, it moves back to sector '63' but as you just tried that
doesn't work.. awesome huh? :wink:

Awesome!

Thanks a lot for your help. It is good to know that the issue is fdisk and not some other variable -- in the eyes of a new person like me, 'other variables' can be a vast ocean!

Bob

In 2.18, we need specify "-c=dos"

I think I fixed it for Fedora 14.

you need to specify "-c=dos -u=cylinders"

I have just now booted Ubuntu from my Beagle xM (rev A2) and I'm updating it for a GUI install.

works for fedora 13 too! yay!

Yeap, that did it... Bob your awesome, i think Andrew was on that same
track before i started talking about using parted instead and
sidetracked him.. :wink:

Pushed to my git repo, there's two more tweaks in want to do to clean
up things, but I'll upload two new images to rcn-ee.net so fedora will
work out of the box for new users.....

Regards,