Trouble connecting BBB to CCSv5.4

Hi there BeagleBoard community!

I am trying to install a BeageBone Black configuration in Code Composer Studio v5.4. I am going to be using a StarterWare type of solution, with my own bootloader but I cannot for the life of me figure out how to get the debugger running in CCSv5.4.

I start by plugging in the BeagleBone and install the x64 drivers that follows with it. I open this guide, but it is no longer applicable. Luckily setting up a target config file is easy - the new CCS supports the Beaglebone natively (I hope that this is the right configuration…).
The problem occurs when I try to launch the debugger - I am given the following error: "IcePick_D_0: Error connecting to the target: (Error -151 @ 0x0) One of the FTDI driver…"

I search around, and find this page which tells me I need to do a PID/VID. I am directed to the CCS FAQ, but the question I was linked to doesn’t really seem to apply to me. It says: "As a rule of thumb: update the Board’s VID and use the latest version of CCSv5 and everything will be fine. "
Well, I am using the latest CCSv5 and I’m trying to get information on the VID updating. Anyway, the FAQ below catches my interested, titled: “Q: My BeagleBone is Rev A5 and greater, but I still can’t connect to my CCS 5.1.1 or greater. Why?” - my exact situation and surprisingly the same error message as an example. I’m directed back to the Circuitco BeableBone wiki support page and go through with the “to-do list” as specified. I even install the now outdated FTDI drivers, the 2.08.14 version (latest version is 2.08.28). But then, I run into trouble again. Running the .BAT file results in this output:



FT_PROG-CmdLine.exe scan prog 0 BBA5.xml
Scanning for devices…
No devices found!
Device 0 does not exist.


So now I’m out of luck. I’ve tried removing and reinstalling the drivers several times, I’ve tried reinstall Code Composer Studio v5.4 one time, reinstalled StarterWare too. I just don’t know what I’m doing wrong - I’m following all specified steps, but it just seems so horribly outdated.

I know this is a lot of reading, but I’d really appreciate if someone stepped out and told me what I’m doing wrong - I just don’t see it.

TL;DR: Cannot activate JTAG emulator in CCSv5.4 for BBB.

This is because the beaglebone black does not have an jtag emulator. The beaglebone black has a serial debug port, and 20 pin jtag pads on the bottom of the board.

William is correct. It will save time to read and understand that these are different boards. They are not the same boards.

You can also read the System Reference Manual as well.


I was not quite sure what you meant by “StarterWare like” application either so I’ll just go ahead and mention that the current version of StarterWare will not work with BBB either. We’ll have to wait until TI puts out an updated version. Assuming they have plans to do such. I do not know if they do plan on doing so, but would assume if they did it would be at or around the time they release 3.8 kernel drivers for the BBB.

Starterware is base code. Very light scheduler, not really an OS. Is is provided by TI.

There is no Starterware support for BeeagleBone Black. Just BeagleBone.


Sorry Gerald, I did not mean to imply they were related, except that perhaps if there were to be an updated version ( including support for the BBB ) that it would happen at or around ( after ? ) time of the “promised” kernel drivers that did not make it at launch time.

Which was what ? SGX drivers ? I do not even know . . . everything I need already seems to be supported.

I am not sure as to their plans so I can’t really answer that question. As it does not use a Linux kernel, that is not really an issue. It is a bare bones implementation It would not take much to convert the BeagleBone SW that is there to work on the Black. Just need someone to do the actual work. It is really a separate effort from what we are focused on.

The SGX was the big piece that was missing. With all the changes in the 3.8 Kernel, it will be a while before that is up and running. I don’t have a schedule on that at the moment.


Thank you so much for your replies William and Gerald.

I’m sorry that I didn’t realize this earlier - I honestly hadn’t even thought of it. I think it’s a bit confusing that the CCS JTAG guide is on the BBB, but I’ll just leave it at that.

Again thank you for clearing this up for me - I’m glad it wasn’t because I did anything wrong (except having the wrong hardware!)

That would be up to the creator of the guide to fix. I suggest you ping them on that.