Trouble setting static IP on update (9/4) Angstrom image

I am trying to set a static IP on my new BBB. The instructions I found here

say ‘modify your /etc/network/interfaces, or make a new file.’

I downloaded the file at

and the flash worked, but now the /etc/network/interfaces file is gone. I made a new one. It looks like this:

root@beaglebone:~# cat /etc/network/interfaces
iface eth0 inet static

(I added the gateway line when it didn’t work without it.)

I can still get to my board via USB, which is fine as a backup, but for my application i need to get a static IP over eth0. Is Angstrom not using /etc/network/interfaces anymore? My network is set up to use 192.168.7.*.

If I can’t use that file how do I set a static IP?

I'd not be happy having the ethernet connection on the same subnet as
the USB one, I think that might be confusing things.

OK. If my usb subnet isn’t defined in /etc/network/interfaces, where is it defined? I’d probably rather change that than my network, for various reasons.

A quick Google suggests it's set in /etc/udhcpd.conf on some BBBs but
mine running Debian has it in /etc/network/interfaces:-

# Ethernet/RNDIS gadget (g_ether)
# ... or on host side, usbnet and random hwaddr
# Note on some boards, usb0 is automaticly setup with an init script
iface usb0 inet static