Trouble using SPI interfaces on new BBBW

Hi, after I setup Wireless on my BBBW, I tried using the SPI interface using this simple Python code:

#import the library
from Adafruit_BBIO.SPI import SPI

spi = SPI(0,0)
When executed using sudo it runs without error. However, using a logic analyzer, I see no activity on either of the SPI pins (spi0 or spi1). I found the config-pin utility and tried using that to set the pins I need to spi. That command worked for the spi0 pins but returned an error (about univerala not being loaded) for spi1. Testing the spi0 pins that did respond to config-pin yielded no results.

Finally, from an earlier conversation in this group, I followed these instructions (minus the eMMC steps) to address loading univerala:

After this I was able to run confi-pin on all spi pins. However when I ran my simple test python script, I saw no output on my logic analyzer and the command froze. I couldn’t CTRL-C out of it and it would not die with a kill -9.

Has anyone been able to use the SPI interfaces? I need to use both at the same time (one as a master, one as a slave) which is why I purchased the BBBW over other boards that only have one SPI interface.

Did you disable hdmi-audio? spi1 is tied up in the audio driver..

With u-boot overlays:

in /boot/uEnv.txt make sure to set:


then reboot and retry with config-pin..


In the link I gave above (I think it was your advice actually) I added these lines to /boot/uEnv.txt:


After rebooting with these settings, config-pin worked on pins P9.28 through P9.31 where previously it complained that universala was not loaded. However, this is also when the python script that tried to write to these pins started to hang.


What version of the Adafruit_BBIO library?

CC'ing Drew, maintainer of that that library. (he's on the road this week)


I’ll check, but I won’t be able to try this until tonight. However this brings up another question; is there something I can try directly on the /dev/* devices to see if there is any problem at that level (and isolate any potential problems in the python lib)?

I’m running Adafruit-BBIO Version: 1.0.0.

Are you still having issues with Adafruit_BBIO?