Trouble with dtc


I am using BBB with Robert Nelsons Ubuntu 13.04 (Sept release I think). Everything has worked perfectly up till now. I am trying to add the UARTS based on the Adafruit python library package. It looks like the dts files are not getting compiled and place in the /lib/firmware directory. So I did a compile test with a sample dts file and it gives me the -@ compiler flag error. research directed me to Robert Nelsons patch at . However when I run this script it ends with the error "Failed to fetch 404 Not found. I went to that site and there are no binary-armhf directories at all. I am stuck. What should i do next? Thanks


Ahh, fix your system?

The script needs, uses dpkg on a debian based system to search for:
bison, flex, build-essential, git-core, iputils-ping...

For anything else, patches welcome..



Thanks for the response and the great tools you supply but I guess due to my “newbie-ness” I don’t understand your reply. Why is the DTC not working and/or thepatch not working on my BBB with Ubuntu so I can compile dts files? Is it just something messed up on my system?


I think it's something messed up with your system..

"Failed to fetch
  404 Not found"

Why is apt fetching from there from the first place? lsb-4.0 doesn't
have any arm repo's, so you must have added it to

So remove that bogus reference. :wink:



YOU ARE DA MAN! I have no idea how that reference to lsb-4.0 got in the sources.list file but once i removed it your script ran perfectly. All is well again! Thanks so much.