Trying to build Angstrom for a TI am335x-evm board

Hey Guys,

I’ve got a question for you guys that I’ve been googling to find the answer for the last day and a half and so far nothing that I’ve changed has fixed it. I’m new to building Angstrom so go easy on me it’s probably just a simple configuration that’s not set correct.

When I run MACHINE=am335x-evm bitbake systemd-gnome-image

I get this “u-boot-denx was skipped: incompatible with machine am335x-evm (not in COMPATIBLE_MACHINE)”

but when I run “MACHINE=beagleboard bitbake systemd-gnome-image”

I don’t get the error.

I know these boards are close to the same and I actually have both of them and I need to be able to build an image for the am335x-evm board and I can’t seem to figure it out. I checked out the “remotes/origin/angstrom-v2013.12-yocto1.5” branch after trying the master branch just in case it was a stability issue but still the same problem.

Some more info that might be helpful but really makes me scratch my head is this.

when I run “MACHINE=am335x-evm bitbake u-boot”

I get these 3 specific errors

ERROR: Nothing PROVIDES ‘u-boot’
ERROR: u-boot was skipped: incompatible with machine am335x-evm (not in COMPATIBLE_MACHINE)
ERROR: u-boot-ti-staging PROVIDES u-boot but was skipped: Either UBOOT_MACHINE or UBOOT_CONFIG must be set in the am335x-evm machine configuration

So I go and check


which has no boot configuration but has

“require conf/machine/include/”

then I check that file to find this

PREFERRED_PROVIDER_u-boot = “u-boot-ti-staging”
PREFERRED_PROVIDER_virtual/kernel = “linux-ti-staging”
UBOOT_MACHINE = “am335x_evm_config”

Also when I check


I find this

KERNEL_DEVICETREE_ti33x = “am335x-evm.dtb am335x-evmsk.dtb am335x-bone.dtb am335x-boneblack.dtb”
COMPATIBLE_MACHINE = “ti33x|ti43x|omap-a15”

Does this have anything to do with Device Tree in the newer kernels and is just ignoring the configs? or am I just missing something?