Trying to Enable UART5 on BB Black

Hello, I am trying to get the UART5 enabled on the BB Black. I have tried using the

cape_enable=capemgr.enable_partno=BB-UART5, and

command in the /boot/uEnv.txt file, but I can’t seem to get the pins (P8_37 and P8_38) to be configured. I am trying to set up a Bluetooth module (HC05) with the UART communication. I have also tried to disable the HDMI using the following command.


Also is there any command I can use to check if UART5 is up and running? I have been using

bone$ dmsg | grep tty05

Any help would be appreciated :slight_smile:

Hello @rhit-saucedm ,

in /boot/uEnv.txt, I usually set up uarts or I can do so from the command line w/ config-pin.

For instance, the people made this utility for muxing pins on the command line.


config-pin p8.37 uart && config-pin p8.38 uart

That should mux your pins for uart on those specific pins.


P.S. If that does not do the trick, please provide your image output via the commands listed below:

uname -a 
cat /etc/dogtag

Hello, @silver2row

I tried doing that, and the tty05 doesn’t appear in my /dev/ directory.




Hello @rhit-saucedm ,

Yeppers, like @RobertCNelson said, the symlinks are either /dev/bone/uart/ or /dev/ttyS5 or others…

What does ls -l /dev/ttyS5 show?


P.S. W/ current images, there are a Compatibility Layer under /dev/bone/ and these files usually work.

Hello @silver2row
@RobertCNelson helped me in finding the solution. A lot of the old BB UART forums say that UART5 is under /dev/tty05 but in recent versions of Linux, it has changed to /dev/ttyS5.

1 Like