Trying to use ttyO0 but I can't disable the console login.

I’ve got a RS232 micro cape that I need to use as a serial port. The problem is that by default /dev/ttyO0 is setup as a login console. I need to disable that so that I can use the port for my own purposes.

I’ve found instructions for how to do it on Rasbian but I can’t find anything for the Beaglebone. I found a line in /etc/inittab that looked like it was starting a getty session on /dev/ttyO0 and I commented it out but after a reboot, the login is still there.

I found some references to inittab being obsolete because systemd doesn’t use it but I can’t find anything to configure systemd so it doesn’t use ttyO0.

Can anyone point me in the right direction?

Some reason you can’t just use one of the other UARTs? It’s very handy to have a serial console for debugging.

ttyo0 has to be disabled in uEnv.txt, and also the board device tree file I believe ( could be wrong on the last part ). Also, systemd may have a service profile for it. I have not looked, and currently am not running systemd. Maybe I’ll check later once I get this rootfs working good, and backed up.

The micro cape I purchased can be either UART0 or UART4 but to change it you have to solder some bridges across some little bitty pads. It looked too delicate for my fat fingers so with this setup, I’m kinda stuck with UART0.

I found the answer here;

My port is at ttyO0. so in my case I entered " systemctl mask serial-getty@ttyO0.service. I was able to confirm the device name by typing “systemctl --full”. My device was in the list.

Once I typed the command above and rebooted, I could use the serial port in my program.

Interesting subject,

in my case I need the Pins used by UART 0 for something else.

In the file

There is a reference to UART 0 :

For those that still need to use ttyO0 for their purpose and not as login console (I won’t ask you why, in my case I simply need 5 uarts) the only thing I had to do on my setup (beagle bone black, with debian-9.5-iot-armhf-2018-08-30) to enable ttyO0 is disable the serial-getty@ttyO0.service as suggested but also the same service on another port serial-getty@ttyS0.service.

Then with:
systemctl mask serial-getty@ttyO0.service

systemctl mask serial-getty@ttyS0.service

you are ready to go and use ttyO0 for your business…