Trying with Make, Cmake, Bazel, Bazelrc, and other Tools to Build the Enormous Package(s)


I am not sure if this patient reply to “myself” is worthy of attention but here goes it:

  1. Building for Tensorflow on the BBAI-64
    a. the current form of bazel in .bazelrc or .bazelversion has not worked for me
    b. I am trying other forms of bazel, i.e. from their github repo, i.e. (as things in Linux are usually backward compatible)
    c. Which should I pick outside of the build that edge_ai_apps builds?

  2. I have tried w/ the given configuration but have not gotten far w/ it
    a. I think the options in .bazelrc are not for tensorflow on the BBAI-64 but .bazelrc does not recognize normal build parameters
    b. Um, I could probably go on for ages about my failures so far building
    c. Do not worry. I will not.

So far,

  1. / Edge Ai Apps · GitLab is what I picked up
  2. I picked it and am trying to build it
  3. The clone works, the builds at specific times work, and the nodes from the edge_ai_apps all give error
  4. I get these nodes from edge_ai_apps that I cannot control for now
    a. dlpack
    b. neo-ai-dlr
    c. model_zoo
    d. edgeai-tiovx-modules
    e. opencv-4.1.0
    f. onnxruntime

a. through f. seem to want to build and I know there are reasons why they are not building completely. The reasons are beyond me currently.

But…w/ all the failure so far, I have come to realize that one man/woman cannot conquer edge_ai_apps by their self.

So, if you have input on how to install one of the libs so far on a. to f. and want to share, please do.

I will keep trying. By the way: PyTorch works on the BBAI-64 now!


P.S. I am not hating on edge_ai_apps and I am not discouraging others from conquering it today. I can build most libs. to about 65% to 89% but each one has their own way of erroring at a non zero number.