Tutorial: Installation of USB Soundcard C-Media Electronics on BeagleBone Black Ubuntu and mpd + mp

Hello,

  1. sudo nano /boot/uboot/uEnv.txt
  2. Edit:

##BeagleBone Black:
##Disable HDMI/eMMC
#capemgr=capemgr.disable_partno=BB-BONELT-HDMI,BB-BONE-EMMC-2G
capemgr=capemgr.disable_partno=BB-BONELT-HDMI,BB-BONE-EMMC-2g capemgr.enable_partno=BB-BONE-AUDI-01

  1. Save with key strg x and y
  2. reboot -t now
  3. sudo apt-get install mpd mpc alsa-utils
  4. aplay -l
    **** List of PLAYBACK Hardware Devices ****
    card 0: Device [Generic USB Audio Device], device 0: USB Audio [USB Audio]
    Subdevices: 0/1
    Subdevice #0: subdevice #0

:slight_smile: nice

  1. sudo nano /etc/mpd.conf
  2. Edit: change lines to

playlist_directory “/home/ubuntu/mpd/playlists”

#log_file “/var/log/mpd/mpd.log”

#state_file “/var/lib/mpd/state”

bind_to_address “127.0.0.1”

An example of an ALSA output:

Thanks Gerry !

I dont run Ubuntu, and currently have another use for my BBB, but I definitely will want to look into this at some point. I will have to adapt to Debian, but should be very close if not exactly the same.

Again, thanks for taking the time to write these steps out.

  1. sudo nano /boot/uboot/uEnv.txt

  2. Edit: change lines to

capemgr=capemgr.disable_partno=BB-BONELT-HDMI,BB-BONE-EMMC-2g

  1. aplay -l
    **** List of PLAYBACK Hardware Devices ****
    card 1: Device [Generic USB Audio Device], device 0: USB Audio [USB Audio]
    Subdevices: 0/1
    Subdevice #0: subdevice #0

  2. Edit: change lines to

device “hw:1,0” # optional
mixer_device “hw:1” # optional

Gerry

  1. Edit: change lines to
    capemgr=capemgr.disable_partno=BB-BONELT-HDMI,BB-BONE-EMMC-2g

Why is it necessary to disable the HDMI video and EMMC device tree overlays ?

Hello,

disable the HDMI: read this https://groups.google.com/forum/#!topic/beagleboard/ZJGwxA7BG4E
I dont need hdmi but need SPI 0 and SPI 1

disable the EMMC-2g: is optional, i dont need this in the moment

Gerry

I want to use my beagle bone black to rip analog signals to my Beagle bone using an audio cape. Does anyone know if I would require a sound card to do so?

Thanks a ton brother :slight_smile:

Hi Gerry,

I am trying to get a USB soundcard C-Meida to work on BeagleBone Black Ubuntu. My Ubuntu is precise 12.04 LTS (ubuntu-precise-12.04.3-armhf-3.8.13-bone30.img.xz)
when I open uEnv.txt I see the following which is different from yours.

mmcpart=2
optargs=fixrtc
uenvcmd=i2c mw 0x24 1 0x3e; kd=0; if test $mmcdev -eq 1; then mmc dev 0; if mmc rescan; then kd=1; fi; mmc dev 1; fi; setenv mmcroot /dev/mmcblk${kd}p${mmcpart} ro
loadfdt=load mmc ${mmcdev}:${mmcpart} ${fdtaddr} ${bootdir}/dtbs/${fdtfile}
loadimage=load mmc ${mmcdev}:${mmcpart} ${loadaddr} ${bootdir}/${bootfile}

I cannot follow your tutorial since the first step is different. Do you have any ideas what is going on?

Thanks a lot.

-Alex

Just add
capemgr=capemgr.disable_partno=BB-BONELT-HDMI,BB-BONE-EMMC-2g
Somewhere in the u-boot env. And reboot bbb.
This will disable stereo audio output via hdmi.
Hope it helps
Priyank.

Hi Thanks for the quick response.

I tried the solution but it did not work.
This is the procedure that I tried:

1- $ lsusb

Bus 001 Device 002: ID 1a40:0101 Terminus Technology Inc. 4-Port HUB

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Bus 001 Device 003: ID 0d8c:000c C-Media Electronics, Inc. Audio Adapter

Bus 001 Device 004: ID 413c:2105 Dell Computer Corp. Model L100 Keyboard

2- $ sudo nano /boot/uboot/uEnv.txt

mmcpart=2

optargs=fixrtc

uenvcmd=i2c mw 0x24 1 0x3e; kd=0; if test $mmcdev -eq 1; then mmc dev 0; if mmc rescan; then kd=1; fi; mmc dev 1; fi; setenv mmcroot /dev/mmcblk${kd}p${mmcpart} ro

loadfdt=load mmc ${mmcdev}:${mmcpart} ${fdtaddr} ${bootdir}/dtbs/${fdtfile}

loadimage=load mmc ${mmcdev}:${mmcpart} ${loadaddr} ${bootdir}/${bootfile}

##BeagleBone Black:

##Disable HDMI/eMMC

#capemgr=capemgr.disable_partno=BB-BONELT-HDMI,BB-BONE-EMMC-2G

capemgr=capemgr.disable_partno=BB-BONELT-HDMI,BB-BONE-EMMC-2g capemgr.enable_partno=BB-BONE-AUDI-01

3- $ sudo reboot
4- $ sudo apt-get install mpd mpc alsa-utils
4- $sudo aplay -l

aplay: device_list:252: no soundcards found…

:frowning: sad

BBB is not seeing the soundcard as you see:(

  • Alex

Just a tid-bit:

I found that you can specify with a config file which sound card to use:

create a file /etc/asound.conf

pcm.!default sysdefault:Device