Two defective BBB - Wireless?

New to BBB development. I purchase a BBB Wireless needed for coursework at my University. First one was purchased in January and worked fine for a couple of weeks. Out of the blue, the BBB would freeze and lose connection. Only way to establish new SSH connection was to unplug it and plug it back in. When it freezes, USR0 will be giving a heartbeat pulse and USR3 will be flashing erratically. It got to the point where I was unable to SSH as the BBB would freeze too quickly to establish connection (withing 15 seconds or so). It was purchased from Arrow and they kindly sent me a new one. Worked fine for a couple of days then started having the exact same issue. I am unable to re-flash a Debain image on either one. I have downloaded new images and re-flashed using etcher 3+ times. Every time, I hold the S2 switch (while disconnected from power) and plug it in. I release my finger when all four LED’s are solid. Once solid, the LED’s will start flashing as if trying to boot instead. Tried with different power supplies, plugged into computer, same result.

Before all SSH possibilities were lost on both, I edited the “cmdline=init=/opt/scripts/tools/eMMC/” line in /boot/uEnv.txt to automatically write the new image to eMMC. I am trying to avoid purchasing a serial debug cable as I only need it for a couple more weeks (and I’m a broke college student) although it would be handy to have for future projects.

Now that I have a second one I find it skeptical that I got two defective units. I wouldn’t think I got two from a batch and thought the Wireless BBB only had the A5 rev released as of now. Really hoping it is user error but I am not sure what I could have done to cause the initial freezing & reboot issue on both.