U-boot dtbo

Hello all…

I am trying to use a newer image than I have in the past:

BeagleBoard.org Debian Image 2017-10-10

I have flashed the eMMC and am able to boot from it with no microSD card in place.

I have been working for the last year with an older (2014) image and I compile and load an overlay.using the capemgr (sudo sh -c “echo DesiredOverlay > /sys/devices/platform/bone_capemgr/slots”) method. I understand from other posts that this is no longer the preferred method, and I need to use the new method. I think I have done what the following suggests:

starting at: U-Boot /boot/uEnv.txt configuration

But I can’t use the same PRU processes as I used before. I get an error (Segmentation fault) that in the previous image would indicate that I had not yet loaded the overlay. I don’t see anything in the dmesg output that would indicate that the uboot/uEnv.txt had run at all.

My questions:

  1. Does it look like I am properly loading the overlay (EBB-PRU-CNKSim-00A0.dtbo) in the uEnv.txt?
  2. Shouldn’t I be able to see this in the dmesg output?
  3. Is there a possibility that the /boot/uEnv.txt is not being run?
  4. Is there an easy way to put tell-tales in the uEnv.txt file so that you could easily see where in the file the process had gotten to?

Thanks in advance,


dmesg_result.txt (23.5 KB)

uEnv.txt (2.04 KB)

I add my custom capes under ###Additional custom capes

I have no problems that way unless i create them in my files
they all load fine

i dont see that cape in my bb.org-overlays/scr/arm directory

Is that custom ?

Hi Wulf Man…Thanks very much for the response. I tried your suggestion of putting the custom cape in the next line, but could not see a change in the dmesg. It really seems like the /boot/uEnv.txt file is not being reference at all.


I’m not quite sure whats the problem is but if its for just enabling and running the PRU along with its I/O’s i prefer to go with cape-universala.

plus I too faced a similar error while programming PRU under kernel 4.+ so later downgraded my kernel to 3.8.45 and enabled cape-universala so it worked for me.

Hope this helps.