u-boot logs not visible on HDMI


I have built an Yocto image for Beaglebone Black. For some reason, the u-boot messages are not visible on my monitor connected via HDMI. But I am able to see the u-boot messages on my serial. Once the system boots, I can see Beaglebone terminal and continue. How do I see u-boot messages as well on HDMI and access the u-boot env. variables from there(via keyboard).

Thanks in advance for your help.

Sai Kiran.

I am not sure if that is possible. You will probably at the very least need to re-compile u-boot. That is assuming it has the required drivers for the BBB video hardware.

Have you tried Googling “u-boot hdmi” There are quite a few topics on this for various boards. May give you a clue.

I am trying to compile the u-boot. But after googling, I am not able to figure out the right drivers for BBB.

it is possible they don’t exist.

OK just checked the u-boot source code and it appears they do have drivers for the am335x framebuffer, (drivers/video/ti) so it should be possible todo.

ohhh… I am trying to load initrd into memory and could not see the initrd messages on serial(UART). So, I was thinking that the messages are visible via HDMI.

Great. Any idea how to enable them in u-boot?

There is an option “Enable AM335X video driver”. Selecting it and trying to build it. Hopefully this works. Let me see.

Thanks @benedict.hewson for the clarification.

This is the error I get. Any thoughts?

sorry no, have never tried to get video output from u-boot.

From the errors it looks like you may need to setup some frame buffer memory.

The HDMI framer used on the bbb doesn’t have a driver in uboot. If you want to see any kernel messages over the HDMI (from the Linux kernel), make sure the kernel config for tilcd and nxp framer are built in and not just enabled as modules.