u-boot stuck

‘Flashed’ a custom angstrom build from SD as i have done many times in the past … (tested the image from the SD a couple of times and was working great)

upon reboot, i get this :


U-Boot SPL 2016.01 (Mar 25 2016 - 14:36:19)
Trying to boot from MMC
reading args
spl_load_image_fat_os: error reading image args, err - -1
reading u-boot.img
reading u-boot.img

U-Boot 2016.01 (Mar 25 2016 - 14:36:19 +0100)

Watchdog enabled
I2C: ready
DRAM: 512 MiB
*** Error - No Valid Environment Area found
*** Warning - bad CRC, using default environment

Net: not set. Validating first E-fuse MAC
cpsw, usb_ether


Won’t boot from SD anymore, can’t type anything … if i try to start it with the “boot” button down, i’m just getting “CCCCCCCCCCC”.
If i can get it to boot from SD i can always try to fix things easily …

How can i unbrick this ? :frowning:

known issue in 2016.01, it was fixed shortly after release.


Alright. good to know.

Though i now bricked my two spare BBBlack … so can’t test if the update doesn’t bug anymore…

Any idea how i can unbrick ?


1: correctly write the MLO/u-boot.img to your microSD card..
2: hold boot button down with finger nail
3: insert power
4: u-boot prompt on serial port..

Grab the good version of u-boot from here:



Thats my issue …

The mSD card i use for flashing that has an “old” MLO/uboot and won’t boot anymore (it’s actually the bbb image you can download on their site that has a “flasher app” in it, i just replace the uboot, mlo, rootfs with my custom builds)

I’ve tried other mSD images i kept from the past that boot on other BBB, but those two BBB that have seen the faulty u-boot won’t try to boot from mSD anymore… i’m really stuck. It’s like it won’t ever try to boot off mSD anymore.
And holding BOOT button just gets me to spi boot (CCCCCCCCCCCC).

i tryed anyther mSD card, just in case mine got busted somehow , but same issue.

"CCC"'s means it can't find the bootloader..

Follow the directions here:



Great !

dd’ing MLO and uboot to the SD card worked !
i repo sync’ed on dev machine, but it’s still building the faulty u-boot. i’ll manually force a newer git version.

Thanks a lot !

CCC come from the onchip boot code